summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Sysadm-Install')
-rw-r--r--dev-perl/Sysadm-Install/Manifest4
-rw-r--r--dev-perl/Sysadm-Install/Sysadm-Install-0.420.0.ebuild23
-rw-r--r--dev-perl/Sysadm-Install/Sysadm-Install-0.430.0.ebuild23
-rw-r--r--dev-perl/Sysadm-Install/Sysadm-Install-0.440.0.ebuild23
-rw-r--r--dev-perl/Sysadm-Install/Sysadm-Install-0.460.0.ebuild23
-rw-r--r--dev-perl/Sysadm-Install/metadata.xml13
6 files changed, 109 insertions, 0 deletions
diff --git a/dev-perl/Sysadm-Install/Manifest b/dev-perl/Sysadm-Install/Manifest
new file mode 100644
index 000000000000..d61534a45954
--- /dev/null
+++ b/dev-perl/Sysadm-Install/Manifest
@@ -0,0 +1,4 @@
+DIST Sysadm-Install-0.42.tar.gz 28896 SHA256 36f636a4f886f3d8a73e89db4875bd207f5e804cdee4f233767793086b3e1306 SHA512 e2c9fab64b131ced8f7a002bd8a03a887a9c614013bf7a938d79019df52c268e4cbc1d4bf3618237a4c8fc1169eb4e08e53cf2eb0fdb0aa520c44194d592c668 WHIRLPOOL 72f70f83153c47fa6b110ce8a5de67e15bb5e3a32e3d27ea212238e8703a5ae23a66de283be16fb803a21ad1631f9fff371a9f958b8e05b482cb77a15cb7cb26
+DIST Sysadm-Install-0.43.tar.gz 28443 SHA256 53238cc922b6f000504216f50003761be68a49503121894b6ed05ea5efd2d849 SHA512 b50a77481b658363860561d24f45104f900c38dbfd18089294a8bc8d4ae9cf937577cd272bc07279e6e4466bf7026cb6947928b749f479fff1dc593ca2c0424f WHIRLPOOL 10cc025ea084cf6721b16957d79606e41fa7c7933d0c40bcd449b64e1f06e0d7c8050bb531ccaeef9fe32c77953963a9d8a10aaae075c62926cefb5183f1ac50
+DIST Sysadm-Install-0.44.tar.gz 26665 SHA256 1e3f80f17e746c86c70d2d126bf613b6ed5e0a57ff3caf9f04ea454d8f0c801f SHA512 6b933187f5c280d899b35b9c26016e0b0868e7af8cb06eeec0bd309c7110b4cb4a9c9853dc6ac505bb441b2677314e9aca412a8ba523f8c4458132e64652ddc4 WHIRLPOOL 5f547bc4db348fc82a7439f0370aadd2f963b4db5529f4a073df7988ad50d3e0526bfd739c7cb1a0a79aaa2822d498dc4b7add30ad4ba0d88855adb467c502b4
+DIST Sysadm-Install-0.46.tar.gz 26560 SHA256 a5464bec7c40daa33b8b8dbcc901369bd094a83d8558ac0444752168d6ddbd23 SHA512 ed9f190529a6d0da7c45f6ed76ab2125124b75bf3211cb7596b717433683170f06b7444434c1d914a2ba3f5a18bcaac69ff5c9df8489ad2331ed442ab1fa208b WHIRLPOOL 3c3f25017b0de49e3fad3a79b1528489b3f83bc82ee5a140ddab2b122b6a3b9c1018f96aec6a0903f7e193c3a27ec0c745a80406ab969fb11ad7b8f3c0acd214
diff --git a/dev-perl/Sysadm-Install/Sysadm-Install-0.420.0.ebuild b/dev-perl/Sysadm-Install/Sysadm-Install-0.420.0.ebuild
new file mode 100644
index 000000000000..0e89fa121775
--- /dev/null
+++ b/dev-perl/Sysadm-Install/Sysadm-Install-0.420.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MSCHILLI
+MODULE_VERSION=0.42
+inherit perl-module
+
+DESCRIPTION="Typical installation tasks for system administrators"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hammer"
+
+RDEPEND="dev-perl/TermReadKey
+ dev-perl/libwww-perl
+ >=dev-perl/Log-Log4perl-1.28
+ hammer? ( dev-perl/Expect )"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/Sysadm-Install/Sysadm-Install-0.430.0.ebuild b/dev-perl/Sysadm-Install/Sysadm-Install-0.430.0.ebuild
new file mode 100644
index 000000000000..5a1c0f833ae8
--- /dev/null
+++ b/dev-perl/Sysadm-Install/Sysadm-Install-0.430.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MSCHILLI
+MODULE_VERSION=0.43
+inherit perl-module
+
+DESCRIPTION="Typical installation tasks for system administrators"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hammer"
+
+RDEPEND="dev-perl/TermReadKey
+ dev-perl/libwww-perl
+ >=dev-perl/Log-Log4perl-1.28
+ hammer? ( dev-perl/Expect )"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/Sysadm-Install/Sysadm-Install-0.440.0.ebuild b/dev-perl/Sysadm-Install/Sysadm-Install-0.440.0.ebuild
new file mode 100644
index 000000000000..84521ce0bdc4
--- /dev/null
+++ b/dev-perl/Sysadm-Install/Sysadm-Install-0.440.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MSCHILLI
+MODULE_VERSION=0.44
+inherit perl-module
+
+DESCRIPTION="Typical installation tasks for system administrators"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hammer"
+
+RDEPEND="dev-perl/TermReadKey
+ dev-perl/libwww-perl
+ >=dev-perl/Log-Log4perl-1.28
+ hammer? ( dev-perl/Expect )"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/Sysadm-Install/Sysadm-Install-0.460.0.ebuild b/dev-perl/Sysadm-Install/Sysadm-Install-0.460.0.ebuild
new file mode 100644
index 000000000000..fde60470fffc
--- /dev/null
+++ b/dev-perl/Sysadm-Install/Sysadm-Install-0.460.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MSCHILLI
+MODULE_VERSION=0.46
+inherit perl-module
+
+DESCRIPTION="Typical installation tasks for system administrators"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hammer"
+
+RDEPEND="dev-perl/TermReadKey
+ dev-perl/libwww-perl
+ >=dev-perl/Log-Log4perl-1.28
+ hammer? ( dev-perl/Expect )"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/Sysadm-Install/metadata.xml b/dev-perl/Sysadm-Install/metadata.xml
new file mode 100644
index 000000000000..4890a99d9c5a
--- /dev/null
+++ b/dev-perl/Sysadm-Install/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <use>
+ <flag name="hammer">Enable hammer() funtion to run a command in the shell and simulate a user
+ hammering the ENTER key to accept defaults on prompts</flag>
+ </use>
+ <upstream>
+ <remote-id type="cpan">Sysadm-Install</remote-id>
+ <remote-id type="cpan-module">Sysadm::Install</remote-id>
+ </upstream>
+</pkgmetadata>