summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-2.7.12.ebuild')
-rw-r--r--dev-lang/python/python-2.7.12.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-lang/python/python-2.7.12.ebuild b/dev-lang/python/python-2.7.12.ebuild
index 2901f8f0870e..992882b2ebd3 100644
--- a/dev-lang/python/python-2.7.12.ebuild
+++ b/dev-lang/python/python-2.7.12.ebuild
@@ -216,7 +216,12 @@ src_compile() {
cd "${BUILD_DIR}" || die
emake
- pax-mark m python
+ # Work around bug 329499. See also bug 413751 and 457194.
+ if has_version dev-libs/libffi[pax_kernel]; then
+ pax-mark E python
+ else
+ pax-mark m python
+ fi
}
src_test() {