summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/jwasm')
-rw-r--r--dev-lang/jwasm/jwasm-2.11a-r1.ebuild (renamed from dev-lang/jwasm/jwasm-2.11a.ebuild)14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-lang/jwasm/jwasm-2.11a.ebuild b/dev-lang/jwasm/jwasm-2.11a-r1.ebuild
index 0eab110f0fbb..2de5e5e9d2b4 100644
--- a/dev-lang/jwasm/jwasm-2.11a.ebuild
+++ b/dev-lang/jwasm/jwasm-2.11a-r1.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs versionator
+inherit toolchain-funcs
# 2.10 -> 210s
MY_PN=JWasm
-MY_PV="$(delete_version_separator 1)s"
+MY_PV="$(ver_rs 1 '')s"
MY_P="${MY_PN}${MY_PV}"
DESCRIPTION="MASM-compatible TASM-similar assembler (fork of Wasm)"
@@ -20,11 +20,15 @@ KEYWORDS="~amd64 ~x86"
RDEPEND=""
DEPEND=""
+BDEPEND="app-arch/unzip"
S="${WORKDIR}"
+PATCHES=("${FILESDIR}"/${PN}-2.11-types-test.patch)
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.11-types-test.patch
+ default
+
# don't strip binary
sed -i GccUnix.mak -e 's/ -s / /g' || die
}