summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/criterion/criterion-0.8.1.0.ebuild')
-rw-r--r--dev-haskell/criterion/criterion-0.8.1.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/criterion/criterion-0.8.1.0.ebuild b/dev-haskell/criterion/criterion-0.8.1.0.ebuild
new file mode 100644
index 000000000000..22fd70deaa22
--- /dev/null
+++ b/dev-haskell/criterion/criterion-0.8.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Robust, reliable performance measurement and analysis"
+HOMEPAGE="https://github.com/bos/criterion"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.3.2.12:=[profile?]
+ >=dev-haskell/binary-0.6.3.0:=[profile?]
+ >=dev-haskell/glob-0.7.2:=[profile?]
+ >=dev-haskell/hastache-0.6.0:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?]
+ >=dev-haskell/mwc-random-0.8.0.3:=[profile?]
+ >=dev-haskell/parsec-3.1.0:=[profile?]
+ >=dev-haskell/statistics-0.11:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-haskell/vector-0.7.1:=[profile?]
+ >=dev-haskell/vector-algorithms-0.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"