summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/fcitx')
-rw-r--r--app-i18n/fcitx/Manifest1
-rw-r--r--app-i18n/fcitx/fcitx-5.1.12.ebuild125
-rw-r--r--app-i18n/fcitx/files/fcitx-5.1.12-make-x11-dependencies-optional.patch24
3 files changed, 150 insertions, 0 deletions
diff --git a/app-i18n/fcitx/Manifest b/app-i18n/fcitx/Manifest
index 9ce45682e7dd..45bb2f5f5633 100644
--- a/app-i18n/fcitx/Manifest
+++ b/app-i18n/fcitx/Manifest
@@ -1,2 +1,3 @@
DIST fcitx-5.1.10.tar.zst 8309913 BLAKE2B a63f5c747dd1d7a519873f00f234ae43d1ab5458e57b809f01e2b6cefc3e3921ecd7fff27cf4b21d59842f11e8d397760d90cf6572b42f65d226b21acc18fefc SHA512 196bc26f7dd50596da90e6b4b0a8b4886b57ec928c182427fb8763507f1f4cb39a252bfddcbd6eccaa0cc920070b7b9fda03f18fd444f84154ddd925678ad7d4
DIST fcitx-5.1.11.tar.zst 8310353 BLAKE2B b38daa03c40b19454cf8b82dc6c9d799730fb614bb606d86f0dfbadb6dd88f3a382f4c2b2a8f820bf4b01e27e27be82ed2624fb3f0a70843af5f72924e62e58b SHA512 d2fee4b931175d67ed29058af5dc644c6918829ca336e88566781ffaf5ccbe942281e9a41459b5ad8ad37756bed24b999127f8b17d8925bb923a9eb10d1081fb
+DIST fcitx-5.1.12.tar.zst 8317084 BLAKE2B 097881acde8fc1cf6960fd20878bb25c483684ff9ad9ffa133081d91fffd50c53b29998b1577866f10a8cb409a3c0fc96766909f6bdf268313e768de79e372ea SHA512 82943f6c2e809e8d9049d457f59e52bc202daf922abec032efc589eefad77b4db4398fbaea92c019eaeaa40ccf51585a8a80676a7909433a8576dc63fb639645
diff --git a/app-i18n/fcitx/fcitx-5.1.12.ebuild b/app-i18n/fcitx/fcitx-5.1.12.ebuild
new file mode 100644
index 000000000000..91033a878585
--- /dev/null
+++ b/app-i18n/fcitx/fcitx-5.1.12.ebuild
@@ -0,0 +1,125 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5"
+
+inherit cmake unpacker xdg
+
+DESCRIPTION="Fcitx 5 is a generic input method framework"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5"
+SRC_URI="https://download.fcitx-im.org/fcitx5/fcitx5/fcitx5-${PV}_dict.tar.zst -> ${P}.tar.zst"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+LICENSE="LGPL-2+ Unicode-DFS-2016"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="+autostart doc +emoji +enchant +keyboard presage +server systemd test wayland +X"
+REQUIRED_USE="
+ || ( wayland X )
+ X? ( keyboard )
+ wayland? ( keyboard )
+"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !app-i18n/fcitx:4
+ dev-libs/libfmt
+ sys-devel/gettext
+ virtual/libintl
+ x11-libs/cairo[X?]
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango[X?]
+ doc? (
+ app-text/doxygen
+ dev-texlive/texlive-fontutils
+ )
+ emoji? ( sys-libs/zlib )
+ enchant? ( app-text/enchant:2 )
+ keyboard? (
+ app-text/iso-codes
+ dev-libs/expat
+ dev-libs/json-c:=
+ x11-misc/xkeyboard-config
+ x11-libs/libxkbcommon[X?,wayland?]
+ )
+ systemd? (
+ sys-apps/systemd
+ )
+ !systemd? (
+ dev-libs/libuv
+ sys-apps/dbus
+ )
+ wayland? (
+ dev-libs/glib:2
+ dev-libs/wayland
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ )
+ X? (
+ dev-libs/glib:2
+ >=x11-libs/xcb-imdkit-1.0.3:5
+ x11-libs/libX11
+ x11-libs/libxkbfile
+ x11-libs/xcb-util
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ kde-frameworks/extra-cmake-modules:0
+"
+
+PATCHES=( "${FILESDIR}"/${P}-make-x11-dependencies-optional.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DBUS=on
+ -DENABLE_XDGAUTOSTART=$(usex autostart)
+ -DENABLE_SERVER=$(usex server)
+ -DENABLE_KEYBOARD=$(usex keyboard)
+ -DENABLE_TEST=$(usex test)
+ -DENABLE_ENCHANT=$(usex enchant)
+ -DENABLE_EMOJI=$(usex emoji)
+ -DENABLE_PRESAGE=$(usex presage)
+ -DENABLE_WAYLAND=$(usex wayland)
+ -DENABLE_X11=$(usex X)
+ -DENABLE_DOC=$(usex doc)
+ -DUSE_SYSTEMD=$(usex systemd)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_src_compile doc
+}
+
+src_install() {
+ cmake_src_install
+ use doc && dodoc -r "${BUILD_DIR}"/doc/*
+}
+
+src_test() {
+ # break by sandbox
+ local CMAKE_SKIP_TESTS=(
+ testdbus
+ testservicewatcher
+ )
+ cmake_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog
+ elog "Follow the instrcutions on:"
+ elog "https://wiki.gentoo.org/wiki/Fcitx#Using_Fcitx"
+ elog "https://fcitx-im.org/wiki/Setup_Fcitx_5"
+ elog "https://fcitx-im.org/wiki/Using_Fcitx_5_on_Wayland"
+ elog
+}
diff --git a/app-i18n/fcitx/files/fcitx-5.1.12-make-x11-dependencies-optional.patch b/app-i18n/fcitx/files/fcitx-5.1.12-make-x11-dependencies-optional.patch
new file mode 100644
index 000000000000..b177316fb7e4
--- /dev/null
+++ b/app-i18n/fcitx/files/fcitx-5.1.12-make-x11-dependencies-optional.patch
@@ -0,0 +1,24 @@
+https://github.com/fcitx/fcitx5/pull/1259
+
+The header may be not available when X11 is disabled. Fixes fcitx5
+build without X11 libraries.
+
+Signed-off-by: Yao Zi <ziyao@disroot.org>
+--- a/src/ui/classic/classicui.cpp
++++ b/src/ui/classic/classicui.cpp
+@@ -20,7 +20,6 @@
+ #include <utility>
+ #include <vector>
+ #include <cairo.h>
+-#include <xcb/xcb.h>
+ #include "fcitx-config/iniparser.h"
+ #include "fcitx-config/rawconfig.h"
+ #include "fcitx-utils/color.h"
+@@ -45,6 +44,7 @@
+ #include "plasmathemewatchdog.h"
+ #include "theme.h"
+ #ifdef ENABLE_X11
++#include <xcb/xcb.h>
+ #include "xcb_public.h"
+ #include "xcbui.h"
+ #endif