summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-physics/fastjet/Manifest1
-rw-r--r--sci-physics/fastjet/fastjet-3.4.3.ebuild89
-rw-r--r--sci-physics/fastjet/fastjet-9999.ebuild89
-rw-r--r--sci-physics/fastjet/metadata.xml3
4 files changed, 182 insertions, 0 deletions
diff --git a/sci-physics/fastjet/Manifest b/sci-physics/fastjet/Manifest
index 4616587b1dd2..dd9023e15b4d 100644
--- a/sci-physics/fastjet/Manifest
+++ b/sci-physics/fastjet/Manifest
@@ -1,2 +1,3 @@
DIST fastjet-3.4.0.tar.gz 2959127 BLAKE2B c99e89ee5cea3fd4e3edebdfebb50efd3c58e7ab15215a384c44120ac930882bd2d4e446b61977fe65dcc49056b958c6510abb7c5889024ae49776b1955bd023 SHA512 af8aeb6197f6bd82ec5f127647f49cd5d455c20e614c23d928b850fc97bc12c70cf6e3b09f1bb0308c2a080fcd4fa13416eea0195695060efaa0e400a687d7b7
DIST fastjet-3.4.2.tar.gz 2973605 BLAKE2B f51b26fdb2611084679a79905c6da460edcf3ad3139bdb2384fe95600e474f4bdb028b24c43456e018c5fb9535491c929d1ec2032d184536efd6b2ef16d54ae1 SHA512 e7702699e67ba5af73f1fe931fe5f67b9f52bb2f0cfdc57dbacf408741e6271ed160503fe6142c92621287df49b441ce7562af589353b199fed09a4c4c839f3f
+DIST fastjet-3.4.3.tar.gz 2984798 BLAKE2B ba203a21c5658555606e4ed83fce4cb3dc0a077b0407c336255a7be2ea861a196d57c2f7db03dbd4dad946b8c68827d0d967b3c009d62232d39827342c7ae492 SHA512 9df7fb6ea1082473929d5963eb58c3d420557a2f52e793432f5bd838e8f7212d0a3c3606b98c3dfeeb3a76ffac73926cb7822aaf499d64a65b2cb2bb845fdb77
diff --git a/sci-physics/fastjet/fastjet-3.4.3.ebuild b/sci-physics/fastjet/fastjet-3.4.3.ebuild
new file mode 100644
index 000000000000..f8b55a9cec69
--- /dev/null
+++ b/sci-physics/fastjet/fastjet-3.4.3.ebuild
@@ -0,0 +1,89 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_NEEDED=plugins
+PYTHON_COMPAT=( python3_{10..12} )
+DOCS_BUILDER="doxygen"
+DOCS_DEPEND="
+ media-gfx/graphviz
+ media-libs/freetype
+ virtual/latex-base
+"
+
+inherit autotools docs flag-o-matic fortran-2 python-single-r1
+
+DESCRIPTION="A software package for jet finding in pp and e+e- collisions"
+HOMEPAGE="https://fastjet.fr/"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/fastjet/fastjet"
+else
+ SRC_URI="https://fastjet.fr/repo/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="cgal examples python +plugins"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# cgal is header-only in version 5.4 and up. We need to use the
+# special --enable-cgal-header-only argument to use these versions.
+DEPEND="
+ cgal? ( >=sci-mathematics/cgal-5.4:=[shared(+)] )
+ plugins? ( sci-physics/siscone:= )
+ python? ( ${PYTHON_DEPS} )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="app-shells/bash"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.4.0-system-siscone.patch
+ "${FILESDIR}"/${PN}-3.4.0-gfortran.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use cgal && \
+ has_version 'sci-mathematics/cgal[gmp]' && append-libs -lgmp
+ # only bash compatible
+ sed -i 's#/bin/sh#/bin/bash#g' ./configure || die
+ econf \
+ $(use_enable cgal cgal-header-only) \
+ $(use_enable plugins allplugins) \
+ $(use_enable plugins allcxxplugins) \
+ --enable-shared \
+ --enable-static=no \
+ --disable-static \
+ --disable-auto-ptr \
+ $(use_enable python pyext)
+}
+
+src_compile() {
+ default
+ docs_compile
+}
+
+src_install() {
+ default
+ use python && python_optimize
+ if use examples; then
+ emake -C example maintainer-clean
+ find example -iname 'makefile*' -delete || die
+
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-physics/fastjet/fastjet-9999.ebuild b/sci-physics/fastjet/fastjet-9999.ebuild
new file mode 100644
index 000000000000..f8b55a9cec69
--- /dev/null
+++ b/sci-physics/fastjet/fastjet-9999.ebuild
@@ -0,0 +1,89 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_NEEDED=plugins
+PYTHON_COMPAT=( python3_{10..12} )
+DOCS_BUILDER="doxygen"
+DOCS_DEPEND="
+ media-gfx/graphviz
+ media-libs/freetype
+ virtual/latex-base
+"
+
+inherit autotools docs flag-o-matic fortran-2 python-single-r1
+
+DESCRIPTION="A software package for jet finding in pp and e+e- collisions"
+HOMEPAGE="https://fastjet.fr/"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/fastjet/fastjet"
+else
+ SRC_URI="https://fastjet.fr/repo/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="cgal examples python +plugins"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# cgal is header-only in version 5.4 and up. We need to use the
+# special --enable-cgal-header-only argument to use these versions.
+DEPEND="
+ cgal? ( >=sci-mathematics/cgal-5.4:=[shared(+)] )
+ plugins? ( sci-physics/siscone:= )
+ python? ( ${PYTHON_DEPS} )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="app-shells/bash"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.4.0-system-siscone.patch
+ "${FILESDIR}"/${PN}-3.4.0-gfortran.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use cgal && \
+ has_version 'sci-mathematics/cgal[gmp]' && append-libs -lgmp
+ # only bash compatible
+ sed -i 's#/bin/sh#/bin/bash#g' ./configure || die
+ econf \
+ $(use_enable cgal cgal-header-only) \
+ $(use_enable plugins allplugins) \
+ $(use_enable plugins allcxxplugins) \
+ --enable-shared \
+ --enable-static=no \
+ --disable-static \
+ --disable-auto-ptr \
+ $(use_enable python pyext)
+}
+
+src_compile() {
+ default
+ docs_compile
+}
+
+src_install() {
+ default
+ use python && python_optimize
+ if use examples; then
+ emake -C example maintainer-clean
+ find example -iname 'makefile*' -delete || die
+
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-physics/fastjet/metadata.xml b/sci-physics/fastjet/metadata.xml
index 8a82eeb2f12f..8e41b6b197d7 100644
--- a/sci-physics/fastjet/metadata.xml
+++ b/sci-physics/fastjet/metadata.xml
@@ -18,4 +18,7 @@
<flag name="cgal"> Use <pkg>sci-mathematics/cgal</pkg> instead of
bundled algorithms</flag>
</use>
+<upstream>
+ <remote-id type="gitlab">fastjet/fastjet</remote-id>
+</upstream>
</pkgmetadata>