summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/qrcode/Manifest1
-rw-r--r--dev-python/qrcode/qrcode-6.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/qrcode/Manifest b/dev-python/qrcode/Manifest
index 12bc9e4e65a7..33b3e69372f4 100644
--- a/dev-python/qrcode/Manifest
+++ b/dev-python/qrcode/Manifest
@@ -1 +1,2 @@
DIST qrcode-5.1.tar.gz 22259 BLAKE2B 1aad710fbfdaa1c1be505038ceedbf02de8bcb2a37ead59265ff03af63b96d6cd740672cb2bd3a8f3b67eb981ed791cf2d53050c02d1499e6efcf1fcce2903c1 SHA512 67a7bb51fe2386f3b1ac0b799d3850d3ca4f61286fdc809654df3f5a1071b503707a9a3e82e595b7611dd9d7b7e74b36e19b86942fb5ad94c256cd7ca9aa02f3
+DIST qrcode-6.1.tar.gz 29363 BLAKE2B 5f31035b6c548c710d0d8198428612fc52417be7af5b5f412a42d264cb6a3ba96de65651049390107cc77e886df2b139942266aba579896f05692177b394ea11 SHA512 4831553932442f5535cba15d5958a656b399112f0f379c28ad9b610c33d88ec6d0613dc7047a2315606e49f027bfd13a15a332ce86b80040d56e1114a0f62251
diff --git a/dev-python/qrcode/qrcode-6.1.ebuild b/dev-python/qrcode/qrcode-6.1.ebuild
new file mode 100644
index 000000000000..b59ee7e4b562
--- /dev/null
+++ b/dev-python/qrcode/qrcode-6.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="QR Code generator on top of PIL"
+HOMEPAGE="https://pypi.org/project/qrcode/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# optional deps:
+# - pillow and lxml for svg backend, set as hard deps
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2) )"
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Testing failed with ${EPYTHON}"
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman doc/qr.1
+}