summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild b/games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild
index d9989a8af10d..b470f0ddf2e6 100644
--- a/games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild
+++ b/games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
+EAPI=5
inherit games
DESCRIPTION="Futuristic FPS (bonus packs)"
@@ -11,8 +12,7 @@ HOMEPAGE="http://www.unrealtournament.com/"
# [UTBonusPack2] -> loki put into games-fps/unreal-tournament
# [UTiNoxxPack] -> loki put into games-fps/unreal-tournament
# [UTBonusPack4] -> none of this is in games-fps/unreal-tournament
-SRC_URI="http://fileserver.talkware.net/ut/bonuspacks/UTBonusPack4.zip
- http://www.dices.de/dices/files/UTBonusPack4.zip"
+SRC_URI="http://fpsnetwork.com/downloads/ut99/bonuspacks/UTBonusPack4.zip"
LICENSE="all-rights-reserved"
SLOT="0"
@@ -20,20 +20,18 @@ KEYWORDS="-* amd64 x86"
IUSE=""
RESTRICT="mirror bindist"
-DEPEND="app-arch/unzip
- || (
- games-fps/unreal-tournament
- games-fps/unreal-tournament-goty )
- games-util/umodpack"
RDEPEND="|| (
games-fps/unreal-tournament
games-fps/unreal-tournament-goty )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ games-util/umodpack"
S=${WORKDIR}
src_install() {
# unpack the UTBonusPack4 umod
- umod -v -b "$(pwd)" -x UTBonusPack4.umod || die "could not unpack UTBonusPack4.umod"
+ umod -v -b "$(pwd)" -x UTBonusPack4.umod || die
# move stuff around
rm UTBonusPack4.umod