summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/rebulk/rebulk-3.1.0-r1.ebuild35
-rw-r--r--dev-python/rebulk/rebulk-3.1.0.ebuild2
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/rebulk/rebulk-3.1.0-r1.ebuild b/dev-python/rebulk/rebulk-3.1.0-r1.ebuild
new file mode 100644
index 000000000000..584c608cc428
--- /dev/null
+++ b/dev-python/rebulk/rebulk-3.1.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library that performs advanced searches in strings"
+HOMEPAGE="
+ https://github.com/Toilal/rebulk/
+ https://pypi.org/project/rebulk/
+"
+SRC_URI="
+ https://github.com/Toilal/rebulk/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Remove base64-encoded zip archive with pytest.
+ rm runtests.py || die
+
+ # Disable unconditional dependency on dev-python/pytest-runner.
+ sed -i -e "s|'pytest-runner'||g" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/rebulk/rebulk-3.1.0.ebuild b/dev-python/rebulk/rebulk-3.1.0.ebuild
index 07104a1fea0b..0b51e9b993f6 100644
--- a/dev-python/rebulk/rebulk-3.1.0.ebuild
+++ b/dev-python/rebulk/rebulk-3.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8