summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-gap/digraphs/Manifest1
-rw-r--r--dev-gap/digraphs/digraphs-1.6.3.ebuild42
-rw-r--r--dev-gap/digraphs/metadata.xml22
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-gap/digraphs/Manifest b/dev-gap/digraphs/Manifest
new file mode 100644
index 000000000000..3be3b40afe6e
--- /dev/null
+++ b/dev-gap/digraphs/Manifest
@@ -0,0 +1 @@
+DIST digraphs-1.6.3.tar.gz 2509307 BLAKE2B 2b0a6dfe84c0f916617a8e2fc83a6bd3005d4719db7fcfa181fc5dc9770362e1e3d7ed7d24d920bca8cb1f617001c2d70b78f9a95da3ccabd32b78801467fa17 SHA512 ef17e8200255e14d4cd7e3cab99a6933b9fb22df1c1b2006f1a8c661f89064e1b3a551c58742ed087ca3a096ac9810398b4459e8e54427309565386310e72081
diff --git a/dev-gap/digraphs/digraphs-1.6.3.ebuild b/dev-gap/digraphs/digraphs-1.6.3.ebuild
new file mode 100644
index 000000000000..ea8b2a5fa00c
--- /dev/null
+++ b/dev-gap/digraphs/digraphs-1.6.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic gap-pkg
+
+DESCRIPTION="Graphs, digraphs, and multidigraphs in GAP"
+SLOT="0"
+SRC_URI="https://github.com/digraphs/Digraphs/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+
+DEPEND="sci-mathematics/gap
+ sci-mathematics/planarity
+ sci-libs/bliss"
+RDEPEND="${DEPEND}
+ dev-gap/io
+ dev-gap/orb
+ dev-gap/datastructures"
+
+DOCS=( CHANGELOG.md README.md )
+
+GAP_PKG_EXTRA_INSTALL=( data notebooks )
+gap-pkg_enable_tests
+
+src_prepare() {
+ default
+
+ # Fix the build with pathological CFLAGS
+ eautoreconf
+}
+
+src_configure() {
+ # https://github.com/digraphs/Digraphs/issues/596
+ append-cflags -Wno-error=strict-prototypes
+
+ gap-pkg_econf \
+ --with-external-planarity \
+ --with-external-bliss
+}
diff --git a/dev-gap/digraphs/metadata.xml b/dev-gap/digraphs/metadata.xml
new file mode 100644
index 000000000000..35d7a398454e
--- /dev/null
+++ b/dev-gap/digraphs/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">digraphs/Digraphs</remote-id>
+ </upstream>
+</pkgmetadata>