summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-power/upower/upower-0.99.5.ebuild3
-rw-r--r--sys-power/upower/upower-0.99.7.ebuild5
2 files changed, 5 insertions, 3 deletions
diff --git a/sys-power/upower/upower-0.99.5.ebuild b/sys-power/upower/upower-0.99.5.ebuild
index 2b214839bb83..c46a822f0a9e 100644
--- a/sys-power/upower/upower-0.99.5.ebuild
+++ b/sys-power/upower/upower-0.99.5.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit ltprune systemd
+inherit ltprune systemd xdg-utils
DESCRIPTION="D-Bus abstraction for enumerating power devices, querying history and statistics"
HOMEPAGE="https://upower.freedesktop.org/"
@@ -76,6 +76,7 @@ src_configure() {
$(use_enable introspection)
$(use_with ios idevice)
)
+ xdg_environment_reset
econf "${myeconfargs[@]}"
}
diff --git a/sys-power/upower/upower-0.99.7.ebuild b/sys-power/upower/upower-0.99.7.ebuild
index a884fe3466cc..b41d3df9819a 100644
--- a/sys-power/upower/upower-0.99.7.ebuild
+++ b/sys-power/upower/upower-0.99.7.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit ltprune systemd
+inherit ltprune systemd xdg-utils
DESCRIPTION="D-Bus abstraction for enumerating power devices, querying history and statistics"
HOMEPAGE="https://upower.freedesktop.org/"
@@ -76,6 +76,7 @@ src_configure() {
$(use_enable introspection)
$(use_with ios idevice)
)
+ xdg_environment_reset
econf "${myeconfargs[@]}"
}