summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/gkrellm/gkrellm-2.3.11-r1.ebuild11
-rw-r--r--app-admin/gkrellm/gkrellm-9999.ebuild11
2 files changed, 8 insertions, 14 deletions
diff --git a/app-admin/gkrellm/gkrellm-2.3.11-r1.ebuild b/app-admin/gkrellm/gkrellm-2.3.11-r1.ebuild
index 39dfbab8031b..50c444a0e35b 100644
--- a/app-admin/gkrellm/gkrellm-2.3.11-r1.ebuild
+++ b/app-admin/gkrellm/gkrellm-2.3.11-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,7 +18,7 @@ else
fi
LICENSE="GPL-3"
SLOT="2"
-IUSE="gnutls hddtemp lm-sensors nls ntlm ssl kernel_FreeBSD X"
+IUSE="gnutls hddtemp lm-sensors nls ntlm ssl X"
RDEPEND="
acct-group/gkrellmd
@@ -66,11 +66,6 @@ pkg_pretend() {
fi
}
-pkg_setup() {
- TARGET=
- use kernel_FreeBSD && TARGET="freebsd"
-}
-
src_prepare() {
sed -e 's:-O2 ::' \
-e 's:override CC:CFLAGS:' \
@@ -85,6 +80,8 @@ src_prepare() {
}
src_compile() {
+ TARGET=
+
if use X ; then
emake \
${TARGET} \
diff --git a/app-admin/gkrellm/gkrellm-9999.ebuild b/app-admin/gkrellm/gkrellm-9999.ebuild
index c88185125116..8b29bcf41db9 100644
--- a/app-admin/gkrellm/gkrellm-9999.ebuild
+++ b/app-admin/gkrellm/gkrellm-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,7 +18,7 @@ else
fi
LICENSE="GPL-3"
SLOT="2"
-IUSE="gnutls hddtemp lm-sensors nls ntlm ssl kernel_FreeBSD X"
+IUSE="gnutls hddtemp lm-sensors nls ntlm ssl X"
RDEPEND="
acct-group/gkrellmd
@@ -66,11 +66,6 @@ pkg_pretend() {
fi
}
-pkg_setup() {
- TARGET=
- use kernel_FreeBSD && TARGET="freebsd"
-}
-
src_prepare() {
sed -e 's:-O2 ::' \
-e 's:override CC:CFLAGS:' \
@@ -85,6 +80,8 @@ src_prepare() {
}
src_compile() {
+ TARGET=
+
if use X ; then
emake \
${TARGET} \