summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnome-extra/gnome-user-docs/Manifest1
-rw-r--r--gnome-extra/gnome-user-docs/gnome-user-docs-45.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/gnome-extra/gnome-user-docs/Manifest b/gnome-extra/gnome-user-docs/Manifest
index a0cc268563b3..06668bc56477 100644
--- a/gnome-extra/gnome-user-docs/Manifest
+++ b/gnome-extra/gnome-user-docs/Manifest
@@ -1 +1,2 @@
DIST gnome-user-docs-44.3.tar.xz 13364796 BLAKE2B 2a8d23154d08c18a699691451f5c37fd6729a6da8ed53b40478f929260fac2c77c01388edbb12edef7e142a322acb163466166aceaa35594143b214e87dabb4c SHA512 c61967958e3d0447d69cc89381896697489e144c3bc3090e1d62cc385a6a7d94501172a11536ba591912a1f8c37c2ef5f8cb299b105f3ac2eabd637fdaa38fdd
+DIST gnome-user-docs-45.0.tar.xz 12655292 BLAKE2B 37b49ec1fadaf8d757be9794598c84cce15ea94cfb1c026dcd2bb874581739384c387cbf83d534f7ac167580214e48985ed70beca10af7eadc86924628c59713 SHA512 9ab39dd408a8c718e4a6629bda1d7a0c917a2d67d84780fcfd29936e577cab8ac4c80654c2404689779d7e4ce4e9e95d217a4244c39f8f653ee8e97533a07a90
diff --git a/gnome-extra/gnome-user-docs/gnome-user-docs-45.0.ebuild b/gnome-extra/gnome-user-docs/gnome-user-docs-45.0.ebuild
new file mode 100644
index 000000000000..90276892b101
--- /dev/null
+++ b/gnome-extra/gnome-user-docs/gnome-user-docs-45.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2
+
+DESCRIPTION="GNOME end user documentation"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-user-docs"
+
+LICENSE="CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+
+BDEPEND="test? ( dev-libs/libxml2 )"
+# eautoreconf requires:
+# app-text/yelp-tools
+# rebuilding translations requires:
+# app-text/yelp-tools
+# dev-util/gettext
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip
+ !test? ( test )"
+
+src_configure() {
+ # itstool is only needed for rebuilding translations
+ # xmllint is only needed for tests
+ gnome2_src_configure \
+ $(usex test "" XMLLINT=$(type -P true)) \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ # Do not compile; "make all" with unset LINGUAS rebuilds all translations,
+ # which can take > 2 hours on a Core i7.
+ return
+}