summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-qt/qtbase/qtbase-6.7.2-r4.ebuild (renamed from dev-qt/qtbase/qtbase-6.7.2-r3.ebuild)11
-rw-r--r--dev-qt/qtbase/qtbase-6.7.9999.ebuild11
-rw-r--r--dev-qt/qtbase/qtbase-6.8.9999.ebuild11
-rw-r--r--dev-qt/qtbase/qtbase-6.9999.ebuild11
4 files changed, 36 insertions, 8 deletions
diff --git a/dev-qt/qtbase/qtbase-6.7.2-r3.ebuild b/dev-qt/qtbase/qtbase-6.7.2-r4.ebuild
index 2782f8186d06..e7e909a26a94 100644
--- a/dev-qt/qtbase/qtbase-6.7.2-r3.ebuild
+++ b/dev-qt/qtbase/qtbase-6.7.2-r4.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit qt6-build toolchain-funcs
+inherit flag-o-matic qt6-build toolchain-funcs
DESCRIPTION="Cross-platform application development framework"
@@ -99,7 +99,7 @@ COMMON_DEPEND="
cups? ( net-print/cups )
gtk? (
x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:3
+ >=x11-libs/gtk+-3.24.41-r1:3[X?,wayland?]
x11-libs/pango
)
)
@@ -170,6 +170,13 @@ src_prepare() {
}
src_configure() {
+ # The only component that uses gdk backends is the qgtk3 platformtheme plugin
+ if use gtk; then
+ # defang automagic dependencies
+ use wayland || append-cxxflags -DGENTOO_GTK_HIDE_WAYLAND
+ use X || append-cxxflags -DGENTOO_GTK_HIDE_X11
+ fi
+
local mycmakeargs=(
-DBUILD_WITH_PCH=OFF
diff --git a/dev-qt/qtbase/qtbase-6.7.9999.ebuild b/dev-qt/qtbase/qtbase-6.7.9999.ebuild
index e4a66f7137f8..580f9e80474a 100644
--- a/dev-qt/qtbase/qtbase-6.7.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.7.9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit qt6-build toolchain-funcs
+inherit flag-o-matic qt6-build toolchain-funcs
DESCRIPTION="Cross-platform application development framework"
@@ -99,7 +99,7 @@ COMMON_DEPEND="
cups? ( net-print/cups )
gtk? (
x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:3
+ >=x11-libs/gtk+-3.24.41-r1:3[X?,wayland?]
x11-libs/pango
)
)
@@ -166,6 +166,13 @@ src_prepare() {
}
src_configure() {
+ # The only component that uses gdk backends is the qgtk3 platformtheme plugin
+ if use gtk; then
+ # defang automagic dependencies
+ use wayland || append-cxxflags -DGENTOO_GTK_HIDE_WAYLAND
+ use X || append-cxxflags -DGENTOO_GTK_HIDE_X11
+ fi
+
local mycmakeargs=(
-DBUILD_WITH_PCH=OFF
diff --git a/dev-qt/qtbase/qtbase-6.8.9999.ebuild b/dev-qt/qtbase/qtbase-6.8.9999.ebuild
index 9af015d9b088..1381d70d7a19 100644
--- a/dev-qt/qtbase/qtbase-6.8.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.8.9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit qt6-build toolchain-funcs
+inherit flag-o-matic qt6-build toolchain-funcs
DESCRIPTION="Cross-platform application development framework"
@@ -99,7 +99,7 @@ COMMON_DEPEND="
cups? ( net-print/cups )
gtk? (
x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:3
+ >=x11-libs/gtk+-3.24.41-r1:3[X?,wayland?]
x11-libs/pango
)
)
@@ -166,6 +166,13 @@ src_prepare() {
}
src_configure() {
+ # The only component that uses gdk backends is the qgtk3 platformtheme plugin
+ if use gtk; then
+ # defang automagic dependencies
+ use wayland || append-cxxflags -DGENTOO_GTK_HIDE_WAYLAND
+ use X || append-cxxflags -DGENTOO_GTK_HIDE_X11
+ fi
+
local mycmakeargs=(
-DBUILD_WITH_PCH=OFF
diff --git a/dev-qt/qtbase/qtbase-6.9999.ebuild b/dev-qt/qtbase/qtbase-6.9999.ebuild
index 9af015d9b088..1381d70d7a19 100644
--- a/dev-qt/qtbase/qtbase-6.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit qt6-build toolchain-funcs
+inherit flag-o-matic qt6-build toolchain-funcs
DESCRIPTION="Cross-platform application development framework"
@@ -99,7 +99,7 @@ COMMON_DEPEND="
cups? ( net-print/cups )
gtk? (
x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:3
+ >=x11-libs/gtk+-3.24.41-r1:3[X?,wayland?]
x11-libs/pango
)
)
@@ -166,6 +166,13 @@ src_prepare() {
}
src_configure() {
+ # The only component that uses gdk backends is the qgtk3 platformtheme plugin
+ if use gtk; then
+ # defang automagic dependencies
+ use wayland || append-cxxflags -DGENTOO_GTK_HIDE_WAYLAND
+ use X || append-cxxflags -DGENTOO_GTK_HIDE_X11
+ fi
+
local mycmakeargs=(
-DBUILD_WITH_PCH=OFF