summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-i18n/ibus/ibus-1.5.22.ebuild12
-rw-r--r--app-i18n/ibus/ibus-1.5.23.ebuild12
-rw-r--r--app-i18n/ibus/ibus-1.5.24.ebuild10
-rw-r--r--app-i18n/ibus/ibus-1.5.25.ebuild10
4 files changed, 6 insertions, 38 deletions
diff --git a/app-i18n/ibus/ibus-1.5.22.ebuild b/app-i18n/ibus/ibus-1.5.22.ebuild
index 3fecbfced783..27e19d610f9f 100644
--- a/app-i18n/ibus/ibus-1.5.22.ebuild
+++ b/app-i18n/ibus/ibus-1.5.22.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -102,14 +102,6 @@ src_prepare() {
src_configure() {
local unicodedir="${EPREFIX}"/usr/share/unicode
- local ucddir
-
- if has_verson '<app-i18n/unicode-data-14.0.0-r1'; then
- ucddir="${unicodedir}-data"
- else
- ucddir=${unicodedir}
- fi
-
local python_conf=()
if use python; then
python_setup
@@ -134,7 +126,7 @@ src_configure() {
$(use_enable nls) \
$(use_enable test tests) \
$(use_enable unicode unicode-dict) \
- $(use_with unicode ucd-dir "${ucddir}") \
+ $(use_with unicode ucd-dir "${EPREFIX}/usr/share/unicode-data") \
$(use_enable vala) \
$(use_enable wayland) \
"${python_conf[@]}"
diff --git a/app-i18n/ibus/ibus-1.5.23.ebuild b/app-i18n/ibus/ibus-1.5.23.ebuild
index c1770f770aa2..d53729503b59 100644
--- a/app-i18n/ibus/ibus-1.5.23.ebuild
+++ b/app-i18n/ibus/ibus-1.5.23.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -111,14 +111,6 @@ src_prepare() {
src_configure() {
local unicodedir="${EPREFIX}"/usr/share/unicode
- local ucddir
-
- if has_verson '<app-i18n/unicode-data-14.0.0-r1'; then
- ucddir="${unicodedir}-data"
- else
- ucddir=${unicodedir}
- fi
-
local python_conf=()
if use python; then
python_setup
@@ -143,7 +135,7 @@ src_configure() {
$(use_enable nls) \
$(use_enable test tests) \
$(use_enable unicode unicode-dict) \
- $(use_with unicode ucd-dir "${ucddir}") \
+ $(use_with unicode ucd-dir "${EPREFIX}/usr/share/unicode-data") \
$(use_enable vala) \
$(use_enable wayland) \
"${python_conf[@]}"
diff --git a/app-i18n/ibus/ibus-1.5.24.ebuild b/app-i18n/ibus/ibus-1.5.24.ebuild
index 2130464553de..ec02e75cce09 100644
--- a/app-i18n/ibus/ibus-1.5.24.ebuild
+++ b/app-i18n/ibus/ibus-1.5.24.ebuild
@@ -112,14 +112,6 @@ src_prepare() {
src_configure() {
local unicodedir="${EPREFIX}"/usr/share/unicode
- local ucddir
-
- if has_verson '<app-i18n/unicode-data-14.0.0-r1'; then
- ucddir="${unicodedir}-data"
- else
- ucddir=${unicodedir}
- fi
-
local python_conf=()
if use python; then
python_setup
@@ -144,7 +136,7 @@ src_configure() {
$(use_enable nls) \
$(use_enable test tests) \
$(use_enable unicode unicode-dict) \
- $(use_with unicode ucd-dir "${ucddir}") \
+ $(use_with unicode ucd-dir "${EPREFIX}/usr/share/unicode-data") \
$(use_enable vala) \
$(use_enable wayland) \
"${python_conf[@]}"
diff --git a/app-i18n/ibus/ibus-1.5.25.ebuild b/app-i18n/ibus/ibus-1.5.25.ebuild
index 91604ca0e0a1..9dc461da301e 100644
--- a/app-i18n/ibus/ibus-1.5.25.ebuild
+++ b/app-i18n/ibus/ibus-1.5.25.ebuild
@@ -113,14 +113,6 @@ src_prepare() {
src_configure() {
local unicodedir="${EPREFIX}"/usr/share/unicode
- local ucddir
-
- if has_verson '<app-i18n/unicode-data-14.0.0-r1'; then
- ucddir="${unicodedir}-data"
- else
- ucddir=${unicodedir}
- fi
-
local python_conf=()
if use python; then
python_setup
@@ -145,7 +137,7 @@ src_configure() {
$(use_enable nls) \
$(use_enable test tests) \
$(use_enable unicode unicode-dict) \
- $(use_with unicode ucd-dir "${ucddir}") \
+ $(use_with unicode ucd-dir "${EPREFIX}/usr/share/unicode-data") \
$(use_enable vala) \
$(use_enable wayland) \
"${python_conf[@]}"