summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/dino/dino-0.3.0-r1.ebuild (renamed from net-im/dino/dino-0.3.0.ebuild)16
-rw-r--r--net-im/dino/dino-9999.ebuild16
2 files changed, 14 insertions, 18 deletions
diff --git a/net-im/dino/dino-0.3.0.ebuild b/net-im/dino/dino-0.3.0-r1.ebuild
index 43f9fadf65e6..3dbdd954e2be 100644
--- a/net-im/dino/dino-0.3.0.ebuild
+++ b/net-im/dino/dino-0.3.0-r1.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-CMAKE_MAKEFILE_GENERATOR="ninja"
inherit cmake vala xdg readme.gentoo-r1
DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
@@ -46,19 +45,18 @@ RDEPEND="
notification-sound? ( media-libs/libcanberra:0[sound] )
"
DEPEND="
- $(vala_depend)
${RDEPEND}
media-libs/gst-plugins-base
media-libs/gstreamer
+"
+BDEPEND="
sys-devel/gettext
+ $(vala_depend)
"
-src_prepare() {
- cmake_src_prepare
- vala_src_prepare
-}
-
src_configure() {
+ vala_setup
+
local disabled_plugins=(
$(usex gpg "" "openpgp")
$(usex omemo "" "omemo")
@@ -86,7 +84,7 @@ src_install() {
readme.gentoo_create_doc
}
-src_postinst() {
+pkg_postinst() {
xdg_pkg_postinst
readme.gentoo_print_elog
}
diff --git a/net-im/dino/dino-9999.ebuild b/net-im/dino/dino-9999.ebuild
index 3b9f5f130391..5362d42a0864 100644
--- a/net-im/dino/dino-9999.ebuild
+++ b/net-im/dino/dino-9999.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-CMAKE_MAKEFILE_GENERATOR="ninja"
inherit cmake vala xdg readme.gentoo-r1
DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
@@ -46,19 +45,18 @@ RDEPEND="
notification-sound? ( media-libs/libcanberra:0[sound] )
"
DEPEND="
- $(vala_depend)
${RDEPEND}
media-libs/gst-plugins-base
media-libs/gstreamer
+"
+BDEPEND="
sys-devel/gettext
+ $(vala_depend)
"
-src_prepare() {
- cmake_src_prepare
- vala_src_prepare
-}
-
src_configure() {
+ vala_setup
+
local disabled_plugins=(
$(usex gpg "" "openpgp")
$(usex omemo "" "omemo")
@@ -86,7 +84,7 @@ src_install() {
readme.gentoo_create_doc
}
-src_postinst() {
+pkg_postinst() {
xdg_pkg_postinst
readme.gentoo_print_elog
}