summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-07 07:46:54 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-07 07:46:54 +0100
commitc5778774521453aa78f3117c033c0cf1b5a807b1 (patch)
tree66416903b7b6d4841d85d2f8eac142a5afadf847 /xfce-extra
parentdev-python/jsonpickle: Remove old (diff)
downloadgentoo-c5778774521453aa78f3117c033c0cf1b5a807b1.tar.gz
gentoo-c5778774521453aa78f3117c033c0cf1b5a807b1.tar.bz2
gentoo-c5778774521453aa78f3117c033c0cf1b5a807b1.zip
xfce-extra/xfce4-weather-plugin: Bump to 0.11.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-weather-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.11.3.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-weather-plugin/Manifest b/xfce-extra/xfce4-weather-plugin/Manifest
index f73ee624142c..2fde40a0fba6 100644
--- a/xfce-extra/xfce4-weather-plugin/Manifest
+++ b/xfce-extra/xfce4-weather-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-weather-plugin-0.11.2.tar.bz2 3096214 BLAKE2B e12d4e0a888b5c9602a0aa0bd595b89bc76a30fa3c250c16c2ddf328d4183c752a624a5e282447b4c987ed4a9ed1dc8e7f9413b3107956e1f67e96fce7213ec8 SHA512 011868165b17501a8b5aacb0387c23be635a1f4037a49501a823cf4aeb2be77d40aad51a4f1d1ccb1057b49e82d4cce2b2cffb82d165cf695340fbab99665ae2
+DIST xfce4-weather-plugin-0.11.3.tar.bz2 3619984 BLAKE2B 45fa193cff7ef04be07944e5fad5dff3de79b5514589608c27917663f00a117cd2a1a34351cc32d2baa977c1e1298910e4de36fd21f504f6bc757bc5e2361783 SHA512 48d0fc1d96848f21196e86678e4aa78360a76ad79d0046b68713a79c9d8746ccffc02d1f6828ff9b14a39ec8b3251db179b02f9e4e77874d4ac8238cbc2353e3
diff --git a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.11.3.ebuild b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.11.3.ebuild
new file mode 100644
index 000000000000..d29b7029f1e1
--- /dev/null
+++ b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.11.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A weather plug-in for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-weather-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-weather-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="upower"
+
+DEPEND="
+ >=dev-libs/glib-2.64.0
+ >=dev-libs/json-c-0.13.1:=
+ dev-libs/libxml2
+ >=net-libs/libsoup-2.42:2.4[ssl]
+ >=x11-libs/gtk+-3.22.0
+ >=xfce-base/libxfce4ui-4.14.0:=
+ >=xfce-base/libxfce4util-4.14.0:=
+ >=xfce-base/xfce4-panel-4.14.0:=
+ >=xfce-base/xfconf-4.12.0:=
+ upower? ( >=sys-power/upower-0.9.23 )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # For GEONAMES_USERNAME, read README file and ask ssuominen@!
+ local myconf=(
+ $(use_enable upower)
+ GEONAMES_USERNAME=Gentoo
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}