summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-03 15:58:55 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-03 15:58:55 +0100
commitbd6aa88581e15f978c0fe222d50cc84aa613dcdd (patch)
treeb977645d84d4bf6722f53fc8a04a52981599afc2 /xfce-extra
parentxfce-extra/xfce4-sensors-plugin: Bump to 1.4.4 (diff)
downloadgentoo-bd6aa88581e15f978c0fe222d50cc84aa613dcdd.tar.gz
gentoo-bd6aa88581e15f978c0fe222d50cc84aa613dcdd.tar.bz2
gentoo-bd6aa88581e15f978c0fe222d50cc84aa613dcdd.zip
xfce-extra/xfce4-systemload-plugin: Bump to 1.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-systemload-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.3.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-systemload-plugin/Manifest b/xfce-extra/xfce4-systemload-plugin/Manifest
index 35aa34f97ffb..8320be82647d 100644
--- a/xfce-extra/xfce4-systemload-plugin/Manifest
+++ b/xfce-extra/xfce4-systemload-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-systemload-plugin-1.3.1.tar.bz2 417959 BLAKE2B c9255349cb4f20a8d8165fbf5a124dbffcb4ca3633c32ca7b2cbbebc4770a50a24909158cd3fcaad9f8bab4b756b98b5329b60a1fbbd0ac0be13251bb950d542 SHA512 2b2285c5960a5728dd7818f90605848e462fe5fef8643ff5be64b7087225399395ace5ec8013f6795d410b0acf79ec77c14e2ed0e56007cfe6f13133ba708876
+DIST xfce4-systemload-plugin-1.3.2.tar.bz2 409767 BLAKE2B 1213c007431318628f4f81026ccdbca2e5b9d34462d66354a1c37999aadc0ef9ed84246bc7f185fd633898364dc0440297dde18288f8beea1d5c7bf6663a6a04 SHA512 f432988f439e5fd7ada16b3e6eaa42b3351531ba3e2b63e2570387bf4d7e605ff9d5a97fde3f5f5eb323ff08aaf3c050f161a5768392b80aa99fabaabda82431
diff --git a/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.3.2.ebuild b/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.3.2.ebuild
new file mode 100644
index 000000000000..986094ce17a5
--- /dev/null
+++ b/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.3.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="System load plug-in for Xfce panel"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-systemload-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-systemload-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="upower"
+
+DEPEND="
+ >=xfce-base/libxfce4ui-4.16:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.17.2:=
+ >=xfce-base/xfce4-panel-4.16:=
+ >=xfce-base/xfconf-4.14:=
+ upower? ( >=sys-power/upower-0.9.23 )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ # gtop is needed only as fallback when /proc is not available
+ --disable-libgtop
+ $(use_enable upower)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}