summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-26 15:42:18 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-26 15:44:15 +0100
commitd50cc3158d17be8ef74e071313ee5e70b61fac06 (patch)
treeca4a84c4969e78c2e504522e1248e8187eafffd5 /xfce-base
parentnet-mail/mu: fix build without python3 (diff)
downloadgentoo-d50cc3158d17be8ef74e071313ee5e70b61fac06.tar.gz
gentoo-d50cc3158d17be8ef74e071313ee5e70b61fac06.tar.bz2
gentoo-d50cc3158d17be8ef74e071313ee5e70b61fac06.zip
xfce-base/xfdesktop: Backport a refresh patch for USE=-wayland
Closes: https://bugs.gentoo.org/904054 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfdesktop/files/xfdesktop-4.19.0-no-wayland.patch37
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.19.0-r1.ebuild (renamed from xfce-base/xfdesktop/xfdesktop-4.19.0.ebuild)8
2 files changed, 44 insertions, 1 deletions
diff --git a/xfce-base/xfdesktop/files/xfdesktop-4.19.0-no-wayland.patch b/xfce-base/xfdesktop/files/xfdesktop-4.19.0-no-wayland.patch
new file mode 100644
index 000000000000..016c1297a06e
--- /dev/null
+++ b/xfce-base/xfdesktop/files/xfdesktop-4.19.0-no-wayland.patch
@@ -0,0 +1,37 @@
+From 84e087b6f36a06d4db503d6aec4bef415b4b5df2 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
+ <congdanhqx@gmail.com>
+Date: Fri, 17 Feb 2023 19:48:52 +0700
+Subject: [PATCH] main: Fix control (always) reach end of non void function
+
+When configured with --disable-wayland, the ENABLE_WAYLAND will be
+dropped, the "return matches" clause will be considered the else
+statement of the "if (xfw_windowing_get() == _X11)", which is always
+false in this scenario. Thus, this function always reach end of
+function without any return values.
+
+While we're at it, fix the comment for the ENABLE_WAYLAND leg.
+---
+ settings/main.c | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/settings/main.c b/settings/main.c
+index 3a1ce17b..410a2d23 100644
+--- a/settings/main.c
++++ b/settings/main.c
+@@ -1740,8 +1740,11 @@ is_our_window(AppearancePanel *panel,
+ matches = TRUE;
+ }
+ // TODO: check window geometry?
++ } else
++#endif /* ENABLE_WAYLAND */
++ {
++ g_assert_not_reached();
+ }
+-#endif /* GTK_WINDOWING_WAYLAND */
+
+ return matches;
+ }
+--
+GitLab
+
diff --git a/xfce-base/xfdesktop/xfdesktop-4.19.0.ebuild b/xfce-base/xfdesktop/xfdesktop-4.19.0-r1.ebuild
index d0c36b0dab6d..514c456fa93d 100644
--- a/xfce-base/xfdesktop/xfdesktop-4.19.0.ebuild
+++ b/xfce-base/xfdesktop/xfdesktop-4.19.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -42,6 +42,12 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ # https://bugs.gentoo.org/904054
+ # https://gitlab.xfce.org/xfce/xfdesktop/-/commit/84e087b6f36a06d4db503d6aec4bef415b4b5df2
+ "${FILESDIR}/${P}-no-wayland.patch"
+)
+
src_configure() {
local myconf=(
$(use_enable wayland)