summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-06 03:59:40 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-06 04:07:40 +0100
commitd14b975415805bbbcada4c82fb97d3f2516eab81 (patch)
tree160aea71d5cf5026dc52b2315b23ea99dbfcf331 /xfce-base
parentxfce-base/garcon: Bump to 4.18.2 (diff)
downloadgentoo-d14b975415805bbbcada4c82fb97d3f2516eab81.tar.gz
gentoo-d14b975415805bbbcada4c82fb97d3f2516eab81.tar.bz2
gentoo-d14b975415805bbbcada4c82fb97d3f2516eab81.zip
xfce-base/garcon: Bump to 4.19.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/garcon/Manifest1
-rw-r--r--xfce-base/garcon/garcon-4.19.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/xfce-base/garcon/Manifest b/xfce-base/garcon/Manifest
index 3e315c2d0734..33a549378a99 100644
--- a/xfce-base/garcon/Manifest
+++ b/xfce-base/garcon/Manifest
@@ -1,3 +1,4 @@
DIST garcon-4.18.1.tar.bz2 554562 BLAKE2B 395cc8f7c7029196f25ecb52d393989ab0df0d9ddd34ec1fc4b0a2ee46b1a059a87c75797adb84d7557523e8e0c464278344fe3d793f05941a90874bdc8e036d SHA512 8e6d091beaf1aaa85cc16cd5e562191e0e6858a47444a23d95066f9afa3f8a70f7a61bc9fec33fe401945637e810441cbd6f961f41b40e2d2ce7a1ce4fce78a0
DIST garcon-4.18.2.tar.bz2 579345 BLAKE2B 2c2c66bb5e53a6dce01cf9dbb8458794f42c06c8db6b526a8ba5c37b73298a7d1fb3f64ef7f9c2036e87903cc6e2afd49fdaedddaec7ecaf8a4b711547945b52 SHA512 f74547a29dbf47469e9448ea0fb89a297d02c7a5d2f7ec1a1f05706f89160730e04743ce84de29de21f32a2d2e4e4410f6c12fd14777c65944529f5104973cee
DIST garcon-4.19.0.tar.bz2 648551 BLAKE2B 0084bf8b72fe1e3e2ac492c4639f84eb330ba37660adf0d5c3c41a4d9e6db3b063e4875f20dbe0a62b0c72bbb06072cb6cd37df057f6e5feb6431f35f87ea045 SHA512 c49304bc69528475318d934a4c565ade7171022f3887c7292e573ccd846137db1e7e325213a73b5a8003869adc35fa73cf5682ec646b2114f4614ae1c076ee9a
+DIST garcon-4.19.1.tar.bz2 655347 BLAKE2B 609403c108638fcbc10485d18d2a0564d8a1137bc9b92e4be0bbafb1615ea1d2f919da2871df22ebdbe3910ceed7f042cfa261df3243910276f9a144124f0125 SHA512 85f3c8991a143636ffd257115f749cb687cfebeeb29ed29a0d6e751bdfe26d0cd121feaad52b16ca2b017d2f2824b1da050db8638c5d6d5e72c7f62934d7f250
diff --git a/xfce-base/garcon/garcon-4.19.1.ebuild b/xfce-base/garcon/garcon-4.19.1.ebuild
new file mode 100644
index 000000000000..aa205c9731cb
--- /dev/null
+++ b/xfce-base/garcon/garcon-4.19.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Xfce's freedesktop.org specification compatible menu implementation library"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/garcon/start
+ https://gitlab.xfce.org/xfce/garcon/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="introspection"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ >=x11-libs/gtk+-3.24.0:3
+ >=xfce-base/libxfce4util-4.15.6:=[introspection?]
+ >=xfce-base/libxfce4ui-4.15.7:=[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ introspection? ( >=dev-libs/gobject-introspection-1.66 )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}