summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-06 04:04:39 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-06 04:07:43 +0100
commitce94a2fa9031666b94071374b710cd7cca93f96d (patch)
treee94953f9b92f9e4f16b6f6c078911c43014a94a0 /xfce-base
parentxfce-base/libxfce4util: Bump to 4.19.3 (diff)
downloadgentoo-ce94a2fa9031666b94071374b710cd7cca93f96d.tar.gz
gentoo-ce94a2fa9031666b94071374b710cd7cca93f96d.tar.bz2
gentoo-ce94a2fa9031666b94071374b710cd7cca93f96d.zip
xfce-base/libxfce4util: Bump to 4.18.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/libxfce4util/Manifest1
-rw-r--r--xfce-base/libxfce4util/libxfce4util-4.18.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/xfce-base/libxfce4util/Manifest b/xfce-base/libxfce4util/Manifest
index 617656eaf139..7c335ba43678 100644
--- a/xfce-base/libxfce4util/Manifest
+++ b/xfce-base/libxfce4util/Manifest
@@ -1,3 +1,4 @@
DIST libxfce4util-4.18.1.tar.bz2 527167 BLAKE2B b5d16b4e6ce541a7de559eb2801cf800dab26c45e83b0c562974f18218fd9ad0d70e40219b573a90f1ea1b9e15a8111cfae6200f581335f305a7e7f6eb07adc9 SHA512 e1459e2268948c8329394bdca56f7e7bef7739b56559c00ce6d70dfbedd038cd73a4873be34b91dbd94a80afc16e2b0e1cc256d3ff4d8fdeef9162fbdb3772cd
+DIST libxfce4util-4.18.2.tar.bz2 514157 BLAKE2B 4c0479d3df308956cecb321783823c3d1f07622260a19b2e7c633a5de6d87a779f1196c10cc5078b01bfabc7ca0cac9a819084414f2dcfbaef3d6d9a69ef3df8 SHA512 94c7371bcfd4ea8dca68a2dc2fe029ce8b232b2b906247bb45a830f13a27833e80831bb6df029d634e6cd8496d4cdcbb9691b6c4344aa51292477f2ebf56bac0
DIST libxfce4util-4.19.2.tar.bz2 622588 BLAKE2B addee65233ce7f6a335b9c072066ea1a4d357e4dce62ecb75cce56aa3d7c27916c141d1124951821f1d4234813a54e51ed933829937adcf0f6c906a4fb65e907 SHA512 85521be421abb3f3c37d7608eae96cb9b2f7ba5b0ac599d2a7501b3b201603fd36ccb13840bd5a3462771e32d81e5814a008baf22df46df7b3b46e4ac8d7e3eb
DIST libxfce4util-4.19.3.tar.bz2 622911 BLAKE2B 0bbe4b6085762d7ab53cb54228cf153e96d6d7c1987bd14fd0f5b0697a0bbf06aa4e969760104b650cc27bfd5a502750e5d1a5b2af7813746bb76528a1c6693d SHA512 0e869f0b850d6454c52a5e43b42ef5f56432ed69774bbf5ba8883d6d2fd8c2e9fccf471c684eb7577617f6286696dfd60ae4f5803c8d45002236289a5d4e5bff
diff --git a/xfce-base/libxfce4util/libxfce4util-4.18.2.ebuild b/xfce-base/libxfce4util/libxfce4util-4.18.2.ebuild
new file mode 100644
index 000000000000..ed4e10c4de0d
--- /dev/null
+++ b/xfce-base/libxfce4util/libxfce4util-4.18.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vala
+
+DESCRIPTION="A basic utility library for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/libxfce4util/start
+ https://gitlab.xfce.org/xfce/libxfce4util/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0/7"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable vala)
+ )
+
+ use vala && vala_setup
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}