summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-01 16:19:42 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-01 16:23:33 +0100
commitcb36ae3f6d669c310da9ca0283b145280795241e (patch)
tree2752680b4a606ab73dc80e18b19edbc14ab88a2d /xfce-base
parentxfce-base/garcon: Bump to 4.19.2 (diff)
downloadgentoo-cb36ae3f6d669c310da9ca0283b145280795241e.tar.gz
gentoo-cb36ae3f6d669c310da9ca0283b145280795241e.tar.bz2
gentoo-cb36ae3f6d669c310da9ca0283b145280795241e.zip
xfce-base/tumbler: Bump to 4.19.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/tumbler/Manifest1
-rw-r--r--xfce-base/tumbler/tumbler-4.19.2.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/xfce-base/tumbler/Manifest b/xfce-base/tumbler/Manifest
index 6f6a7bb56f41..36e5e710d06c 100644
--- a/xfce-base/tumbler/Manifest
+++ b/xfce-base/tumbler/Manifest
@@ -1,2 +1,3 @@
DIST tumbler-4.18.2.tar.bz2 619513 BLAKE2B d93b6dc3b0da1b8ed04af740dec4979daba376572f36e80e6f33c791552a8615fc9f6d6452b0008030a83b322179d1a6f8daa6e5a60344ba09706d0d34de270a SHA512 043e4e7058d1bf0eb4f037924161387042111c7a1bfbf78f8417d0b6463d6b7e72506741f395ca14d6150e2cc0b79d97b2ee3270a30e0d18a0161f639627e255
DIST tumbler-4.19.1.tar.bz2 704299 BLAKE2B e6b24c5f9393d661b409001d02db29c36c74ae241279c2880e20cd2935eb16429ab105023ec918014e8899abe0dfa1fe199d2cb7ba22fefda3f0a4db58aded62 SHA512 ed38c9263741dc8c621974eb058a970b8e50c9e0efa551945a12e836fabc8015a4d70c2a558271b11a9783d6778bbacb886c0925618ff0f7850a5680580e2e4d
+DIST tumbler-4.19.2.tar.bz2 705102 BLAKE2B 9eb1f6bc39bb4db37709ab9ef126e81359cdbd65073fbc383f5f206f84afd13576350a9d46c4016b8d53af01e531038b43b391e760ead71d3107b92aef0dd40a SHA512 cce6b445e6551985103f88215b28f6aedbed085504361d9d525f13735776454ccd7904d1b8f5c847946f5481f4c1bb6fa2a4f3ab36d33046c07d2e6151db9c5a
diff --git a/xfce-base/tumbler/tumbler-4.19.2.ebuild b/xfce-base/tumbler/tumbler-4.19.2.ebuild
new file mode 100644
index 000000000000..9e164b062b29
--- /dev/null
+++ b/xfce-base/tumbler/tumbler-4.19.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A thumbnail service for Thunar"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/tumbler/start
+ https://gitlab.xfce.org/xfce/tumbler/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="curl epub ffmpeg gstreamer jpeg odf pdf raw"
+
+DEPEND="
+ >=dev-libs/glib-2.72.0
+ media-libs/freetype:2=
+ media-libs/libpng:0=
+ >=sys-apps/dbus-1.6
+ >=xfce-base/libxfce4util-4.17.1:=
+ >=x11-libs/gdk-pixbuf-2.42.8
+ curl? ( >=net-misc/curl-7.32.0:= )
+ epub? ( app-text/libgepub )
+ ffmpeg? ( >=media-video/ffmpegthumbnailer-2.0.8:= )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ )
+ jpeg? ( media-libs/libjpeg-turbo:0= )
+ odf? ( >=gnome-extra/libgsf-1.14.20:= )
+ pdf? ( >=app-text/poppler-0.12.4[cairo] )
+ raw? ( >=media-libs/libopenraw-0.0.8:=[gtk] )
+"
+RDEPEND="
+ ${DEPEND}
+ gstreamer? ( media-plugins/gst-plugins-meta:1.0 )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable curl cover-thumbnailer)
+ $(use_enable epub gepub-thumbnailer)
+ $(use_enable jpeg jpeg-thumbnailer)
+ $(use_enable ffmpeg ffmpeg-thumbnailer)
+ $(use_enable gstreamer gstreamer-thumbnailer)
+ $(use_enable odf odf-thumbnailer)
+ $(use_enable pdf poppler-thumbnailer)
+ $(use_enable raw raw-thumbnailer)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}