summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-01 08:52:55 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-01 08:53:58 +0100
commitbe1e891bb62c6a9477168026dfa1ff85763c500b (patch)
tree50b90211dac326b4eec12545bbdcc6dcdbf9fbb1 /xfce-base/exo
parentdev-db/timescaledb: drop 2.15.3 (diff)
downloadgentoo-be1e891bb62c6a9477168026dfa1ff85763c500b.tar.gz
gentoo-be1e891bb62c6a9477168026dfa1ff85763c500b.tar.bz2
gentoo-be1e891bb62c6a9477168026dfa1ff85763c500b.zip
xfce-base/exo: Bump to 4.19.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/exo')
-rw-r--r--xfce-base/exo/Manifest1
-rw-r--r--xfce-base/exo/exo-4.19.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/xfce-base/exo/Manifest b/xfce-base/exo/Manifest
index cb4f69b8f241..9ad71668ca4f 100644
--- a/xfce-base/exo/Manifest
+++ b/xfce-base/exo/Manifest
@@ -1,2 +1,3 @@
DIST exo-4.18.0.tar.bz2 896849 BLAKE2B 99cd22b9f2c806907449afdd640abd85be2ec37269d0436a20300ac88ee4fbe39807e39ba51ae8fe82d621c478d65d1f452209779e7d48caee899305b40f3a27 SHA512 32f3a319ff31a37cdaf8e2e7bdbdbaa9b797d6731a27854838b47d6078f45af83ed1a664aef4663f616fd9abcae9233c6f68ab2cc18599f1b2ced487602c51ce
DIST exo-4.19.0.tar.bz2 1095228 BLAKE2B e0a368032d3cb148a9bda96e5eeb6a9364a568e809f1c0c31d13e82e1357c22e401a8ec486e19da8001fe7ff7570870fecd5564d2ccdc38947ddb51e5eec00df SHA512 656ec021c19618daafd80df6701e7076ad167520388cbc1727d22da9c6b4eaa4f7e12b53f6131f2d2e10986b0440cbf808aeb6914c1a91d2e7af711c015967fc
+DIST exo-4.19.1.tar.bz2 1096455 BLAKE2B 07557851e9920e39442421a148041661948eb81501f15a0173591947214fcc63fb961c094ac122568eb486615d58aa54a37811069eda4331f7d3e7472225b49b SHA512 2a1c4ca1c82ea19834b2205521950a71604ca179531f81d0c98bdf174a842fe6d274c4640b9e0488d8fb6aef012473ae7cf48b93e62009a50d908dd9b508c0b1
diff --git a/xfce-base/exo/exo-4.19.1.ebuild b/xfce-base/exo/exo-4.19.1.ebuild
new file mode 100644
index 000000000000..6aaa054a074f
--- /dev/null
+++ b/xfce-base/exo/exo-4.19.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/exo/start
+ https://gitlab.xfce.org/xfce/exo/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+
+DEPEND="
+ >=dev-libs/glib-2.72.0
+ >=x11-libs/gtk+-3.24.0:3
+ >=xfce-base/libxfce4ui-4.15.1:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.17.2:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}