summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-05-08 23:37:07 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-05-09 23:52:01 +0200
commitc0ec0343c4f653126f27768902f86c6492f92ec0 (patch)
tree3d199849c1bfb1f137923bfcd97e214a67471f34 /x11-wm
parentx11-wm/lwm: clean up old. (diff)
downloadgentoo-c0ec0343c4f653126f27768902f86c6492f92ec0.tar.gz
gentoo-c0ec0343c4f653126f27768902f86c6492f92ec0.tar.bz2
gentoo-c0ec0343c4f653126f27768902f86c6492f92ec0.zip
x11-wm/lwm: EAPI 6 bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/lwm/lwm-1.2.3-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-wm/lwm/lwm-1.2.3-r1.ebuild b/x11-wm/lwm/lwm-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..e9c2c04cd628
--- /dev/null
+++ b/x11-wm/lwm/lwm-1.2.3-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="The ultimate lightweight window manager"
+SRC_URI="http://www.jfc.org.uk/files/lwm/${P}.tar.gz"
+HOMEPAGE="http://www.jfc.org.uk/software/lwm.html"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+"
+
+DEPEND="
+ ${RDEPEND}
+ x11-misc/imake
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+
+DOCS=( AUTHORS BUGS ChangeLog )
+
+src_prepare() {
+ default
+ sed -i -e "s#(SMLIB)#& -lICE#g" Imakefile || die #370127
+ xmkmf || die
+}
+
+src_compile() {
+ emake \
+ EXTRA_LDOPTIONS="${CFLAGS} ${LDFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ CC="$(tc-getCC)" \
+ "${PN}"
+}
+
+src_install() {
+ dobin "${PN}"
+ newman "${PN}.man" "${PN}.1"
+ einstalldocs
+}