summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/windowlab
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/windowlab')
-rw-r--r--x11-wm/windowlab/Manifest2
-rw-r--r--x11-wm/windowlab/files/windowlab-1.34-fixed-font.patch11
-rw-r--r--x11-wm/windowlab/files/windowlab-1.40-gentoo.diff53
-rw-r--r--x11-wm/windowlab/metadata.xml17
-rw-r--r--x11-wm/windowlab/windowlab-1.34.ebuild55
-rw-r--r--x11-wm/windowlab/windowlab-1.40.ebuild53
6 files changed, 191 insertions, 0 deletions
diff --git a/x11-wm/windowlab/Manifest b/x11-wm/windowlab/Manifest
new file mode 100644
index 000000000000..9daa1f98fde6
--- /dev/null
+++ b/x11-wm/windowlab/Manifest
@@ -0,0 +1,2 @@
+DIST windowlab-1.34.tar 163840 SHA256 a646abd1a7b1c548621ba8fcadc32311555e89f2a45b78a0f105421d618e4d35
+DIST windowlab-1.40.tar 174080 SHA256 1c9cca5d997cfdcec093e98b7f1996da2d806fbbe4472bdcca568863f3e75d93
diff --git a/x11-wm/windowlab/files/windowlab-1.34-fixed-font.patch b/x11-wm/windowlab/files/windowlab-1.34-fixed-font.patch
new file mode 100644
index 000000000000..0dd095ce0733
--- /dev/null
+++ b/x11-wm/windowlab/files/windowlab-1.34-fixed-font.patch
@@ -0,0 +1,11 @@
+--- windowlab.h.orig 2006-09-01 23:47:36.000000000 +0200
++++ windowlab.h 2006-09-01 23:47:49.000000000 +0200
+@@ -49,7 +49,7 @@
+ #ifdef XFT
+ #define DEF_FONT "-bitstream-bitstream vera sans-medium-r-*-*-*-100-*-*-*-*-*-*"
+ #else
+-#define DEF_FONT "-b&h-lucida-medium-r-*-*-10-*-*-*-*-*-*-*"
++#define DEF_FONT "fixed"
+ #endif
+
+ // use named colours, #rgb, #rrggbb or #rrrgggbbb format
diff --git a/x11-wm/windowlab/files/windowlab-1.40-gentoo.diff b/x11-wm/windowlab/files/windowlab-1.40-gentoo.diff
new file mode 100644
index 000000000000..121526ceac8b
--- /dev/null
+++ b/x11-wm/windowlab/files/windowlab-1.40-gentoo.diff
@@ -0,0 +1,53 @@
+--- Makefile.orig 2009-11-05 21:04:45.000000000 +0000
++++ Makefile 2010-05-30 15:31:04.047559352 +0000
+@@ -5,18 +5,18 @@
+ EXTRA_LIBS += -lXext
+
+ # Set this to the hardcoded location of all files if it's not /
+-PREFIX = /usr/local
++PREFIX = /usr
+
+ # Set this to the directory, below PREFIX, where man pages
+ # are expected. Below this directory, the target "install"
+ # will put "windowlab.1x" in section "man1".
+-MANBASE = /man
++MANBASE = /share/man
+
+ # Set this to the location of the X installation you want to compile against
+-XROOT = /usr/X11R6
++XROOT = /usr
+
+ # Some flexibility for configuration location
+-CONFPREFIX = $(PREFIX)
++CONFPREFIX =
+ CONFDIR = /etc/X11/windowlab
+
+ # Set this to the location of the global configuration files
+@@ -43,7 +43,6 @@
+
+ # --------------------------------------------------------------------
+
+-CC = gcc
+ ifndef CFLAGS
+ CFLAGS = -g -O2 -Wall -W
+ endif
+@@ -63,15 +62,15 @@
+ all: $(PROG)
+
+ $(PROG): $(OBJS)
+- $(CC) $(OBJS) $(LDPATH) $(LIBS) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) $(LDPATH) $(LIBS) -o $@
+
+ $(OBJS): %.o: %.c $(HEADERS)
+ $(CC) $(CFLAGS) $(DEFINES) $(INCLUDES) -c $< -o $@
+
+ install: all
+- mkdir -p $(BINDIR) && install -m 755 -s $(PROG) $(BINDIR)
+- mkdir -p $(MANDIR) && install -m 644 $(MANPAGE) $(MANDIR) && gzip -9vfn $(MANDIR)/$(MANPAGE)
+- mkdir -p $(CFGDIR) && cp -i windowlab.menurc $(CFGDIR)/windowlab.menurc && chmod 644 $(CFGDIR)/windowlab.menurc
++ install -D -m 755 $(PROG) $(BINDIR)/$(PROG)
++ install -D -m 644 $(MANPAGE) $(MANDIR)/windowlab.1
++ install -D -m 644 windowlab.menurc $(CFGDIR)/windowlab.menurc
+
+ clean:
+ rm -f $(PROG) $(OBJS)
diff --git a/x11-wm/windowlab/metadata.xml b/x11-wm/windowlab/metadata.xml
new file mode 100644
index 000000000000..8579926063c0
--- /dev/null
+++ b/x11-wm/windowlab/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+ <longdescription>
+ WindowLab is a small and simple window manager of novel design.
+
+ It has a click-to-focus but not raise-on-focus policy, a
+ window resizing mechanism that allows one or many edges of a
+ window to be changed in one action, and an innovative menubar
+ that shares the same part of the screen as the taskbar. Window
+ titlebars are prevented from going off the edge of the screen
+ by constraining the mouse pointer, and when appropriate the
+ pointer is also constrained to the taskbar/menubar in order to
+ make target menu items easier to hit.
+ </longdescription>
+</pkgmetadata>
diff --git a/x11-wm/windowlab/windowlab-1.34.ebuild b/x11-wm/windowlab/windowlab-1.34.ebuild
new file mode 100644
index 000000000000..5dd232c87ae4
--- /dev/null
+++ b/x11-wm/windowlab/windowlab-1.34.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="small and simple window manager of novel design"
+HOMEPAGE="http://www.nickgravgaard.com/windowlab/"
+SRC_URI="http://www.nickgravgaard.com/${PN}/${P}.tar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc x86"
+IUSE="truetype"
+
+RDEPEND="truetype? ( x11-libs/libXft )
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.34-fixed-font.patch"
+}
+
+src_compile() {
+ if use truetype ; then
+ export DEFINES=-DXFT
+ export EXTRA_INC=$(pkg-config --cflags xft)
+ export EXTRA_LIBS=$(pkg-config --libs xft)
+ fi
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin ${PN} || die
+
+ newman ${PN}.1x ${PN}.1 || die
+ dodoc CHANGELOG README TODO || die
+
+ dodir /etc/X11/${PN} || die
+ insinto /etc/X11/${PN}
+ doins ${PN}.menurc || die
+
+ dodir /etc/X11/Sessions || die
+ echo "/usr/bin/${PN}" > ${D}/etc/X11/Sessions/${PN}
+ fperms a+x /etc/X11/Sessions/${PN}
+}
+
+pkg_postinst() {
+ elog "${PN}'s menu config file has been changed from"
+ elog "/etc/X11/${PN}/menurc to /etc/X11/${PN}/${PN}.menurc"
+}
diff --git a/x11-wm/windowlab/windowlab-1.40.ebuild b/x11-wm/windowlab/windowlab-1.40.ebuild
new file mode 100644
index 000000000000..a80b77bb9ecd
--- /dev/null
+++ b/x11-wm/windowlab/windowlab-1.40.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="small and simple window manager of novel design"
+HOMEPAGE="http://www.nickgravgaard.com/windowlab/"
+SRC_URI="http://www.nickgravgaard.com/${PN}/${P}.tar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+IUSE="truetype"
+
+RDEPEND="truetype? ( x11-libs/libXft )
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if use truetype ; then
+ export DEFINES=-DXFT
+ export EXTRA_INC=$(pkg-config --cflags xft)
+ export EXTRA_LIBS=$(pkg-config --libs xft)
+ fi
+ tc-export CC
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.34-fixed-font.patch" \
+ "${FILESDIR}"/${P}-gentoo.diff
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc CHANGELOG README TODO || die
+
+ exeinto /etc/X11/Sessions
+ cat <<- EOF > "${T}"/${PN}
+ #!/bin/sh
+ exec /usr/bin/${PN}
+ EOF
+ doexe "${T}"/${PN}
+}
+
+pkg_postinst() {
+ elog "${PN}'s menu config file has been changed from"
+ elog "/etc/X11/${PN}/menurc to /etc/X11/${PN}/${PN}.menurc"
+}