summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé María Alonso Josa <nimiux@gentoo.org>2016-02-27 21:49:44 +0100
committerJosé María Alonso Josa <nimiux@gentoo.org>2016-02-27 21:50:54 +0100
commit2dd623a3c9fcd3ba7641e72d876125812c637af8 (patch)
tree4ecf0c89b4f03c29f7166bc90cc5aa68a99d6602 /x11-wm/stumpwm
parentMerge github#922: dev-lang/go: add ~amd64-fbsd, ~x86-fbsd keyword. (diff)
downloadgentoo-2dd623a3c9fcd3ba7641e72d876125812c637af8.tar.gz
gentoo-2dd623a3c9fcd3ba7641e72d876125812c637af8.tar.bz2
gentoo-2dd623a3c9fcd3ba7641e72d876125812c637af8.zip
x11-wm/stumpwm: Fix config for contrib use flag
Diffstat (limited to 'x11-wm/stumpwm')
-rw-r--r--x11-wm/stumpwm/stumpwm-0.9.9.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/x11-wm/stumpwm/stumpwm-0.9.9.ebuild b/x11-wm/stumpwm/stumpwm-0.9.9.ebuild
index 29808a6e8aa5..00a90c7d1db8 100644
--- a/x11-wm/stumpwm/stumpwm-0.9.9.ebuild
+++ b/x11-wm/stumpwm/stumpwm-0.9.9.ebuild
@@ -72,7 +72,10 @@ src_prepare() {
}
src_configure() {
- econf --with-lisp=$(get_lisp sbcl clisp ecl) --with-module-dir="${CLSOURCEROOT}/${CLPACKAGE}/contrib"
+ local moduleconfig
+
+ use contrib && moduleconfig="--with-module-dir=${CLSOURCEROOT}/${CLPACKAGE}/contrib"
+ econf --with-lisp=$(get_lisp sbcl clisp ecl) "${moduleconfig}"
}
src_compile() {