summaryrefslogtreecommitdiff
path: root/x11-wm/i3
diff options
context:
space:
mode:
authorNelo-T. Wallus <nelo@wallus.de>2020-10-22 20:17:06 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-10-25 20:26:47 +0100
commit8ccd4dfee3003892ae8f1c6e6751a9fa9f59f7bc (patch)
tree8c01b0ffdc01de1e1f0c2cdd71d7686cc6101fd8 /x11-wm/i3
parentapp-admin/monit: Bump to version 5.27.1 (diff)
downloadgentoo-8ccd4dfee3003892ae8f1c6e6751a9fa9f59f7bc.tar.gz
gentoo-8ccd4dfee3003892ae8f1c6e6751a9fa9f59f7bc.tar.bz2
gentoo-8ccd4dfee3003892ae8f1c6e6751a9fa9f59f7bc.zip
x11-wm/i3: Bump to v4.18.3
Package-Manager: Portage-3.0.5, Repoman-2.3.23 Signed-off-by: Nelo-T. Wallus <nelo@wallus.de> Closes: https://github.com/gentoo/gentoo/pull/18003 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-wm/i3')
-rw-r--r--x11-wm/i3/Manifest1
-rw-r--r--x11-wm/i3/i3-4.18.3.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/x11-wm/i3/Manifest b/x11-wm/i3/Manifest
index 88a378d3834f..f4ce02652a2d 100644
--- a/x11-wm/i3/Manifest
+++ b/x11-wm/i3/Manifest
@@ -2,4 +2,5 @@ DIST i3-4.14.tar.gz 3936748 BLAKE2B 42678130be56bc695e5700e978ddbd34bfdaeda7a652
DIST i3-4.17.1.tar.bz2 1218418 BLAKE2B eb798eee2b618691ceb47b72c08fe09b09e2913c17fe667fab95426069c86497bff67278bea5fc97fdf90ebdfc6574e68cad36b21036a63d053edced1edf8592 SHA512 af397dc1768ea6530e4b2ce8ef21b20ecff8ab9eebf380df224456173eea4c3bacf28b55c8efcdc70f76f0d66543c163564a94cfd66028221ace481fa3c2913f
DIST i3-4.18.1.tar.bz2 1217703 BLAKE2B 469a6ac09004f95861655858c47d9e6b2f378152bec7b7c6e7b08f06ee387043b8e2c382f888f14daf806ae8764d934025118e997f072709eee23c5cc52de21d SHA512 b001f539b1daf78be6dd9335a7c0474d30f8d969f79d131391ebd9ca310a058a1cc1234e4a9e60552efd520fc4983571f3c0b8cbd7be978e45957daaf86b3e90
DIST i3-4.18.2.tar.bz2 1218440 BLAKE2B 55fba66b2399730cb3bc63d76efff18a439aad755c943f06d7622bd7c4d91502b3750cff638b98ef86d6f99746bc1858ffbd9396e2d89a7220f513575879e08a SHA512 997c7cdf32f95ba25cfcd483a09f7e37e5219e4501baefa5c1865ddffd206bc9725211e4082663fab4174dc947b663ff454d343a7e30340ac3ea451f999417fc
+DIST i3-4.18.3.tar.bz2 1218766 BLAKE2B c394bbe9882dc893107f0c948632a3a79c52db75b75b2890f6f43fa60d80ce82d1c8a8c32a8793f59d9a6f929ab038765dbe3813c3c6bc1b79bebbbbde772451 SHA512 61599b79247ec546819bab22666a78fc8dc77eecbcf6055efb6b52720290fa7f72719ac6670396a6dfb54858781e438b5207c15fdf2cf9e2424a1b84ffeb749c
DIST i3-4.18.tar.bz2 1218591 BLAKE2B 582b7ba3a54edf8dd2657add05eb54a64b7c004761a1a248d91dfcb061cb9df215ff35301c125b11aa69b571daeacd5732b498934c1fb17f69404a101fd16ec8 SHA512 0bbfda7f4b20a92a50ffb6abbfc3f6bfe6bb4c987ad4b5b1791192eb23b8c3389cc9949a699901797370c14de1ff8e12447a3b8ce330ab7d300fafdb60a432ec
diff --git a/x11-wm/i3/i3-4.18.3.ebuild b/x11-wm/i3/i3-4.18.3.ebuild
new file mode 100644
index 000000000000..58a3f832182c
--- /dev/null
+++ b/x11-wm/i3/i3-4.18.3.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools out-of-source virtualx
+
+DESCRIPTION="An improved dynamic tiling window manager"
+HOMEPAGE="https://i3wm.org/"
+SRC_URI="https://i3wm.org/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc debug test"
+
+CDEPEND="dev-libs/libev
+ dev-libs/libpcre
+ dev-libs/yajl
+ x11-libs/libxcb[xkb]
+ x11-libs/libxkbcommon[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+ x11-misc/xkeyboard-config
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/pango[X]"
+DEPEND="${CDEPEND}
+ test? (
+ dev-perl/AnyEvent
+ dev-perl/X11-XCB
+ dev-perl/Inline
+ dev-perl/Inline-C
+ dev-perl/IPC-Run
+ dev-perl/ExtUtils-PkgConfig
+ dev-perl/local-lib
+ virtual/perl-Test-Simple
+ x11-base/xorg-server[xephyr]
+ x11-misc/xvfb-run
+ )"
+RDEPEND="${CDEPEND}
+ dev-lang/perl
+ dev-perl/AnyEvent-I3
+ dev-perl/JSON-XS"
+BDEPEND="virtual/pkgconfig"
+
+# Test without debug will apply optimization levels, which results
+# in type-punned pointers - which in turn causes test failures.
+REQUIRED_USE="test? ( debug )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.16-musl-GLOB_TILDE.patch"
+)
+
+# https://github.com/i3/i3/issues/3013
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ cat <<- EOF > "${T}"/i3wm
+ #!/bin/sh
+ exec /usr/bin/i3
+ EOF
+
+ eautoreconf
+}
+
+my_src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+my_src_test() {
+ emake check
+}
+
+my_src_install_all() {
+ doman man/*.1
+
+ einstalldocs
+ use doc && dodoc -r docs "RELEASE-NOTES-${PV}"
+
+ exeinto /etc/X11/Sessions
+ doexe "${T}/i3wm"
+}
+
+pkg_postinst() {
+ # Only show the elog information on a new install
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "There are several packages that you may find useful with ${PN} and"
+ elog "their usage is suggested by the upstream maintainers, namely:"
+ elog " x11-misc/dmenu"
+ elog " x11-misc/i3status"
+ elog " x11-misc/i3lock"
+ elog "Please refer to their description for additional info."
+ fi
+}