summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-05-31 07:28:54 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-05-31 08:14:52 -0400
commit4f03d19061fd14f26b2a15fa107248b0efb3aa3c (patch)
tree4b1ca4d209e6b7ac01978ed8e71d27ed129f8d4b /x11-terms
parentmedia-sound/grip: Stabilize 4.2.4-r1 ppc, #933252 (diff)
downloadgentoo-4f03d19061fd14f26b2a15fa107248b0efb3aa3c.tar.gz
gentoo-4f03d19061fd14f26b2a15fa107248b0efb3aa3c.tar.bz2
gentoo-4f03d19061fd14f26b2a15fa107248b0efb3aa3c.zip
x11-terms/kitty-shell-integration: add 0.35.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty-shell-integration/Manifest1
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.35.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
index d50956701c0d..b961d43c8857 100644
--- a/x11-terms/kitty-shell-integration/Manifest
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -1,3 +1,4 @@
DIST kitty-0.33.1.tar.xz 8166164 BLAKE2B 6592ae99f3e05bda5367186096804175f00f21770e7112bf45fa968d161e70d2fdcf956214e29e048e6973ee14457f5eaca753a761824f1c104ba32552122e33 SHA512 5fa2421baf9fac41d4a8ff89bb5e44d1820012e8c960e25980d597dcebbb44ffa97c03818e8a91015691321eedb9d9f53139a97cbb6bd673053fbfd73c77739b
DIST kitty-0.34.1.tar.xz 8176176 BLAKE2B c39709a065a04b04bf15e6decb9a96c1699c1082de44690c36e4e05a288f6835fa3c5dd059c363a272c98934b5c66cf5d79078b6403c7f15a9e94f3f72aa680c SHA512 1b361823741c8c2a6ce3c5d56d0cbbd51bd0a0d2574312ef5c05f359c70862e0889a9636e4b95865750cbd239b517763315ed0cf4ec46e1feaffc27cf20e0e66
DIST kitty-0.35.0.tar.xz 8206476 BLAKE2B 1c03ed7f3bde0c67790cc47da8afc14d31d21513456004042c48451f4b5fc0891de85e467a16029a1f49b90ba6652f4e356d5101c8d773852b614da3f153692d SHA512 b8c310237b1f0e48c1490f1bcfa009490d1592557bd81d6593a2a3ce71696ab03b3d91bb1dc32212adea70a4e6b5491ea6604d43517e679151df49e11b8de604
+DIST kitty-0.35.1.tar.xz 8206388 BLAKE2B cb50b1d6011cf5eac61175c07a8365004c22505363a0a43114f010e6d47388959b308343124b427422797836d6b0e1954ec278301d98ff33acd103d611052727 SHA512 aecda31410b8d52ec7df5a9947f29be04249fadb6af24ee7e0cbb649f09a9e510d9fe6913d24d10c36ef7227187c96a1e3f25a8da840a16ed0bcb8cb46f1f089
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.35.1.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.35.1.ebuild
new file mode 100644
index 000000000000..a50a1338ca92
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.35.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash/,/etc/bash/bashrc.d/90-}kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+
+ # this is used internally by the ssh kitten and is not useful there
+ rm -r "${ED}"/usr/share/kitty/shell-integration/ssh || die
+}