summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-02-07 06:35:04 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-02-07 06:44:17 -0500
commit576c9b25a3b5503d987ebe6c92378746110c5345 (patch)
tree36a5f7abc21c6aef327014eb742cfeddd6a3bbd4 /x11-terms/kitty-terminfo/kitty-terminfo-0.27.1.ebuild
parentx11-terms/kitty-shell-integration: add 0.27.1 (diff)
downloadgentoo-576c9b25a3b5503d987ebe6c92378746110c5345.tar.gz
gentoo-576c9b25a3b5503d987ebe6c92378746110c5345.tar.bz2
gentoo-576c9b25a3b5503d987ebe6c92378746110c5345.zip
x11-terms/kitty-terminfo: add 0.27.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms/kitty-terminfo/kitty-terminfo-0.27.1.ebuild')
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.27.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.27.1.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.27.1.ebuild
new file mode 100644
index 000000000000..f29634123585
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.27.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+BDEPEND="sys-libs/ncurses"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/terminfo
+ tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
+}