summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-07-30 22:36:43 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2019-07-30 22:47:04 +0200
commit1dd944fb6ef06ade266522f8d01e812029e4adbf (patch)
tree38b4588e2997811ebf38f821da11358098b1933c /x11-plugins
parentx11-plugins/wmamixer: drop old (diff)
downloadgentoo-1dd944fb6ef06ade266522f8d01e812029e4adbf.tar.gz
gentoo-1dd944fb6ef06ade266522f8d01e812029e4adbf.tar.bz2
gentoo-1dd944fb6ef06ade266522f8d01e812029e4adbf.zip
x11-plugins/wmamixer: add missing alsa-lib dependency
Closes: https://bugs.gentoo.org/690358 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmamixer/wmamixer-1.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/wmamixer/wmamixer-1.0-r1.ebuild b/x11-plugins/wmamixer/wmamixer-1.0-r1.ebuild
new file mode 100644
index 000000000000..a73c156da7f8
--- /dev/null
+++ b/x11-plugins/wmamixer/wmamixer-1.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="ALSA mixer dockapp, fork of wmsmixer"
+HOMEPAGE="https://github.com/gryf/wmamixer"
+SRC_URI="https://github.com/gryf/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib
+ x11-libs/libXpm
+ x11-libs/libXext
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+DOCS=( README.rst )
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} -c -o wmamixer.o wmamixer.c
+ $(tc-getCC) ${LDFLAGS} -o wmamixer wmamixer.o -lm -lXpm -lXext -lX11 -lasound
+}
+
+src_install() {
+ dobin wmamixer
+ einstalldocs
+}