summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmtime
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmtime')
-rw-r--r--x11-plugins/wmtime/Manifest5
-rw-r--r--x11-plugins/wmtime/metadata.xml5
-rw-r--r--x11-plugins/wmtime/wmtime-1.0_beta2_p10.ebuild61
-rw-r--r--x11-plugins/wmtime/wmtime-1.0_beta2_p9.ebuild61
-rw-r--r--x11-plugins/wmtime/wmtime-1.1.ebuild39
-rw-r--r--x11-plugins/wmtime/wmtime-1.2.ebuild36
6 files changed, 207 insertions, 0 deletions
diff --git a/x11-plugins/wmtime/Manifest b/x11-plugins/wmtime/Manifest
new file mode 100644
index 000000000000..806b4144b07f
--- /dev/null
+++ b/x11-plugins/wmtime/Manifest
@@ -0,0 +1,5 @@
+DIST wmtime-1.1.tar.gz 23263 SHA256 4fc70c8b0d14212055891181bd6af86552efb45be8fb2e2ae135bb9861fc103e SHA512 e32e20be4c1dcab9bf0f16eb8d1703e90360430ea176e9e04e0f8735240c54d4dc4d0bbf29a2902cfb12df5995280eb924d621ada2d1e836efdf755065de5636 WHIRLPOOL 1469175b4d7f10d4afcdce07798a4644125bc00e912b63a2e98ffd26ed0e190256f89af2c9159d40db8ea99150a3324586f27ec8b983df18a71613ef5946469d
+DIST wmtime-1.2.tar.gz 23219 SHA256 ff39675d2c51e1d0774bdc181f27966fcf8f063bb0a4c8cfda9c83d9978a0b1a SHA512 d81be07012a9efd93a51219d6b63a76d88c8916af0b3ed990c3005621f643c70fadc31ebc8fef11c1605f303bc3e036c2014809c5368f4acaff8b7a1c1665c15 WHIRLPOOL 18067140573474c6b5ad3d01c00b353b55e6caee05cf474e0daf9483b9cab58df4d6dfcecbca53cc6015417f122f8ae920277359de682c7b9943ed09e8368b55
+DIST wmtime_1.0b2-10.diff.gz 8631 SHA256 91c5220d4487765771168e890be11741fe8428878c905512a51555af7c3a970f
+DIST wmtime_1.0b2-9.diff.gz 8234 SHA256 189512286950bd5f8ab41d41c3ccbeee8811be95519ef9b03b12aeadded8312d
+DIST wmtime_1.0b2.orig.tar.gz 20483 SHA256 a526b95a16b8451ee9a05b57d97251e3d9efd5e7b7143d3592767b87a3941375
diff --git a/x11-plugins/wmtime/metadata.xml b/x11-plugins/wmtime/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmtime/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmtime/wmtime-1.0_beta2_p10.ebuild b/x11-plugins/wmtime/wmtime-1.0_beta2_p10.ebuild
new file mode 100644
index 000000000000..c0aa5ce49055
--- /dev/null
+++ b/x11-plugins/wmtime/wmtime-1.0_beta2_p10.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs versionator
+
+MY_PV="$(get_version_component_range 1-2)"
+MY_PL="$(get_version_component_range 3)"
+MY_PL="${MY_PL/beta/b}"
+MY_PV="${MY_PV}${MY_PL}"
+MY_PL="$(get_version_component_range 4)"
+MY_PL="${MY_PL/p/}"
+
+IUSE=""
+
+DESCRIPTION="applet which displays the date and time in a dockable tile"
+SRC_URI="mirror://debian/pool/main/w/wmtime/wmtime_${MY_PV}.orig.tar.gz
+ mirror://debian/pool/main/w/wmtime/wmtime_${MY_PV}-${MY_PL}.diff.gz"
+HOMEPAGE="http://packages.qa.debian.org/w/wmtime.html"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${PN}-${MY_PV}.orig/${PN}
+
+src_prepare() {
+ cd "${WORKDIR}"
+
+ # apply debian patch
+ epatch ${PN}_${MY_PV}-${MY_PL}.diff
+
+ # honour Gentoo LDFLAGS, bug #335799
+ sed -i "s/-o wmtime/\$(LDFLAGS) -o wmtime/" "${S}/Makefile"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install () {
+ dobin wmtime
+ doman wmtime.1
+
+ cd ..
+ dodoc BUGS CHANGES HINTS README TODO
+
+ # install sample config file, too
+ dodoc debian/wmtimerc
+}
diff --git a/x11-plugins/wmtime/wmtime-1.0_beta2_p9.ebuild b/x11-plugins/wmtime/wmtime-1.0_beta2_p9.ebuild
new file mode 100644
index 000000000000..5258825dab53
--- /dev/null
+++ b/x11-plugins/wmtime/wmtime-1.0_beta2_p9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils versionator
+
+MY_PV="$(get_version_component_range 1-2)"
+MY_PL="$(get_version_component_range 3)"
+MY_PL="${MY_PL/beta/b}"
+MY_PV="${MY_PV}${MY_PL}"
+MY_PL="$(get_version_component_range 4)"
+MY_PL="${MY_PL/p/}"
+
+IUSE=""
+
+DESCRIPTION="applet which displays the date and time in a dockable tile"
+SRC_URI="http://ftp.debian.org/debian/pool/main/w/wmtime/wmtime_${MY_PV}.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/w/wmtime/wmtime_${MY_PV}-${MY_PL}.diff.gz"
+HOMEPAGE="http://packages.qa.debian.org/w/wmtime.html"
+
+SLOT="0"
+KEYWORDS="~amd64 x86"
+LICENSE="GPL-2"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${PN}-${MY_PV}.orig/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}"
+
+ # apply debian patch
+ epatch "${PN}_${MY_PV}-${MY_PL}.diff"
+
+ # honour Gentoo LDFLAGS, bug #335799
+ sed -i "s/-o wmtime/\$(LDFLAGS) -o wmtime/" "${S}/Makefile"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install () {
+ dobin wmtime
+ doman wmtime.1
+
+ cd ..
+ dodoc BUGS CHANGES HINTS README TODO
+
+ # install sample config file, too
+ dodoc debian/wmtimerc
+}
diff --git a/x11-plugins/wmtime/wmtime-1.1.ebuild b/x11-plugins/wmtime/wmtime-1.1.ebuild
new file mode 100644
index 000000000000..46e9eb3ce8d1
--- /dev/null
+++ b/x11-plugins/wmtime/wmtime-1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="applet which displays the date and time in a dockable tile"
+HOMEPAGE="http://windowmaker.org/dockapps/?name=wmtime"
+# Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+S=${WORKDIR}/dockapps/${PN}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install () {
+ dobin wmtime
+ doman wmtime.1
+
+ cd ..
+ dodoc BUGS CHANGES HINTS README TODO
+}
diff --git a/x11-plugins/wmtime/wmtime-1.2.ebuild b/x11-plugins/wmtime/wmtime-1.2.ebuild
new file mode 100644
index 000000000000..158e6848c45c
--- /dev/null
+++ b/x11-plugins/wmtime/wmtime-1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="applet which displays the date and time in a dockable tile"
+HOMEPAGE="http://windowmaker.org/dockapps/?name=wmtime"
+# Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/dockapps
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install () {
+ emake DESTDIR="${D}" PREFIX=/usr install
+
+ dodoc BUGS CHANGES HINTS README TODO
+}