summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-10-10 12:15:08 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2022-10-10 12:15:31 +0200
commitc10ab0fd3849d3139386532b42c94b09ecef79c1 (patch)
tree601297a76993cf7d00d5ab1fc7ff81cd200fbf51 /x11-plugins/wmsystemtray/wmsystemtray-1.4-r3.ebuild
parentdev-java/mockito: fix SRC_URI (slot 0), allow higher Java versions (diff)
downloadgentoo-c10ab0fd3849d3139386532b42c94b09ecef79c1.tar.gz
gentoo-c10ab0fd3849d3139386532b42c94b09ecef79c1.tar.bz2
gentoo-c10ab0fd3849d3139386532b42c94b09ecef79c1.zip
x11-plugins/wmsystemtray: depend on media-fonts/font-misc-misc
Closes: https://bugs.gentoo.org/874678 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins/wmsystemtray/wmsystemtray-1.4-r3.ebuild')
-rw-r--r--x11-plugins/wmsystemtray/wmsystemtray-1.4-r3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-plugins/wmsystemtray/wmsystemtray-1.4-r3.ebuild b/x11-plugins/wmsystemtray/wmsystemtray-1.4-r3.ebuild
new file mode 100644
index 000000000000..4c9322846e2b
--- /dev/null
+++ b/x11-plugins/wmsystemtray/wmsystemtray-1.4-r3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools
+
+DESCRIPTION="a system tray dockapp with the ability to display more than just four tray icons"
+HOMEPAGE="https://sourceforge.net/projects/wmsystemtray/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXmu
+ x11-libs/libXpm"
+RDEPEND="${DEPEND}
+ media-fonts/font-misc-misc"
+
+PATCHES=( "${FILESDIR}"/${P}-ar.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}