summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmfrog
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmfrog')
-rw-r--r--x11-plugins/wmfrog/Manifest2
-rw-r--r--x11-plugins/wmfrog/files/01-fix-segfault-0.2.0.patch54
-rw-r--r--x11-plugins/wmfrog/files/02-buffer-overflow-0.2.0.patch60
-rw-r--r--x11-plugins/wmfrog/metadata.xml8
-rw-r--r--x11-plugins/wmfrog/wmfrog-0.2.0-r1.ebuild37
-rw-r--r--x11-plugins/wmfrog/wmfrog-0.3.1.ebuild37
6 files changed, 198 insertions, 0 deletions
diff --git a/x11-plugins/wmfrog/Manifest b/x11-plugins/wmfrog/Manifest
new file mode 100644
index 000000000000..b17fdab8b890
--- /dev/null
+++ b/x11-plugins/wmfrog/Manifest
@@ -0,0 +1,2 @@
+DIST wmfrog-0.2.0.tgz 59113 SHA256 9471daf33a87ebab26a0f2477f86caa6d956f3f06771d58ce0b506049e2defb5
+DIST wmfrog-0.3.1.tgz 128499 SHA256 01929419c30ea50fbae28bb18ea26a53bb8a6b9b83c7d7d469bac867397616cb
diff --git a/x11-plugins/wmfrog/files/01-fix-segfault-0.2.0.patch b/x11-plugins/wmfrog/files/01-fix-segfault-0.2.0.patch
new file mode 100644
index 000000000000..7e88f49058ff
--- /dev/null
+++ b/x11-plugins/wmfrog/files/01-fix-segfault-0.2.0.patch
@@ -0,0 +1,54 @@
+From 7b9ead8d480eb2be07db646e9c6383f3397beaea Mon Sep 17 00:00:00 2001
+From: Jim Ramsay <lack@gentoo.org>
+Date: Thu, 6 Aug 2009 12:22:26 -0400
+Subject: [PATCH] Fixed segfault if Weather or Clouds not present
+
+Though the variables 'weatherFound' and 'cloudsFound' were being set properly by
+fscanf, their values were never actually checked.
+
+Furthermore, the strings (Weather, Clouds, tmp1 and tmp2) were not being
+initialized to NULL as the code seems to have been expecting.
+---
+ Src/wmFrog.c | 12 ++++++------
+ 1 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/Src/wmFrog.c b/Src/wmFrog.c
+index e2d82af..af4101a 100644
+--- a/Src/wmFrog.c
++++ b/Src/wmFrog.c
+@@ -68,10 +68,10 @@ int n, s, m, i, dt1, dt2, dt3 ;
+ XEvent event;
+ char command[1024], Line[512], FileName[10];
+ FILE *fp;
+- char* Weather;
+- char* Clouds;
+- char* tmp1;
+- char* tmp2;
++ char* Weather = NULL;
++ char* Clouds = NULL;
++ char* tmp1 = NULL;
++ char* tmp2 = NULL;
+ int intensity=0;
+ char* precip;
+ char* desc;
+@@ -238,7 +238,7 @@ FILE *fp;
+ keepgoing=1;
+ {
+
+- do{
++ if (weatherFound) do{
+
+
+ tmp1=mystrsep(&Weather,";");
+@@ -289,7 +289,7 @@ FILE *fp;
+ while(keepgoing);
+ }
+
+- do{
++ if (cloudsFound) do{
+ tmp1=mystrsep(&Clouds,";");
+ if(tmp1)
+ {
+--
+1.6.3.3
+
diff --git a/x11-plugins/wmfrog/files/02-buffer-overflow-0.2.0.patch b/x11-plugins/wmfrog/files/02-buffer-overflow-0.2.0.patch
new file mode 100644
index 000000000000..c4267585836c
--- /dev/null
+++ b/x11-plugins/wmfrog/files/02-buffer-overflow-0.2.0.patch
@@ -0,0 +1,60 @@
+From 5cc2198aebf090b399bd8aaea0e1c8b054bbda58 Mon Sep 17 00:00:00 2001
+From: Jim Ramsay <i.am@jimramsay.com>
+Date: Thu, 6 Aug 2009 12:51:56 -0400
+Subject: [PATCH] Remove buffer overflows
+
+Replaced all 'sprintf' calls with 'snprintf' and fixed all buffers to reasonable
+sizes.
+---
+ Src/wmFrog.c | 11 +++++------
+ 1 files changed, 5 insertions(+), 6 deletions(-)
+
+diff --git a/Src/wmFrog.c b/Src/wmFrog.c
+index af4101a..74e8b56 100644
+--- a/Src/wmFrog.c
++++ b/Src/wmFrog.c
+@@ -66,7 +66,7 @@ char* folder;
+ int main(int argc, char *argv[]) {
+ int n, s, m, i, dt1, dt2, dt3 ;
+ XEvent event;
+-char command[1024], Line[512], FileName[10];
++char command[1024], Line[512], FileName[128];
+ FILE *fp;
+ char* Weather = NULL;
+ char* Clouds = NULL;
+@@ -213,7 +213,7 @@ FILE *fp;
+
+ dt2 = 0;
+
+- sprintf(FileName, "%s/%s", folder, StationID);
++ snprintf(FileName, 128, "%s/%s", folder, StationID);
+ fprintf(stderr,"%s\n\n",FileName);
+ if ((fp = fopen(FileName, "r")) != NULL){
+ fscanf(fp, "Hour:%d", &hour);
+@@ -571,7 +571,7 @@ UpToDate = 0;
+ /*
+ * Execute Perl script to grab the Latest METAR Report
+ */
+- sprintf(command, "/usr/lib/wmfrog/weather.pl %s %s &", StationID, folder);
++ snprintf(command, 1024, "/usr/lib/wmfrog/weather.pl %s %s &", StationID, folder);
+ //printf("Retrieveing data\n");
+ system(command);
+ ForceDownload = 0;
+@@ -844,12 +844,11 @@ char *GetTempDir(char *suffix)
+ {
+ uid_t id;
+ struct passwd *userEntry;
+- char * userHome;
++ static char userHome[128];
+
+ id=getuid();
+ userEntry=getpwuid(id);
+- userHome=userEntry->pw_dir;
+- sprintf(userHome,"%s/%s",userHome,suffix);
++ snprintf(userHome, 128, "%s/%s", userEntry->pw_dir, suffix);
+ return userHome;
+ }
+
+--
+1.6.3.3
+
diff --git a/x11-plugins/wmfrog/metadata.xml b/x11-plugins/wmfrog/metadata.xml
new file mode 100644
index 000000000000..eb748357d59a
--- /dev/null
+++ b/x11-plugins/wmfrog/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+ <upstream>
+ <remote-id type="sourceforge">wmfrog</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-plugins/wmfrog/wmfrog-0.2.0-r1.ebuild b/x11-plugins/wmfrog/wmfrog-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..c0b4f59989f4
--- /dev/null
+++ b/x11-plugins/wmfrog/wmfrog-0.2.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="a weather application, it shows the weather in a graphical way"
+HOMEPAGE="http://wiki.colar.net/wmfrog_dockapp"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+S=${WORKDIR}/Src
+
+src_prepare() {
+ epatch "${FILESDIR}"/*-${PV}.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" INCDIR="" \
+ LIBDIR="" SYSTEM="${LDFLAGS}" || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc ../{CHANGES,HINTS}
+}
diff --git a/x11-plugins/wmfrog/wmfrog-0.3.1.ebuild b/x11-plugins/wmfrog/wmfrog-0.3.1.ebuild
new file mode 100644
index 000000000000..b6788b1c40e1
--- /dev/null
+++ b/x11-plugins/wmfrog/wmfrog-0.3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="a weather application, it shows the weather in a graphical way"
+HOMEPAGE="http://wiki.colar.net/wmfrog_dockapp"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+S=${WORKDIR}/Src
+
+src_prepare() {
+ emake clean || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" INCDIR="" \
+ LIBDIR="" SYSTEM="${LDFLAGS}" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ../{CHANGES,HINTS} || die
+}