summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-07-09 14:39:01 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2022-07-09 17:40:53 +0200
commite55849e2f21b1d1b6cb0d08b59ec708093ca2da8 (patch)
tree2210b29b56a2eded7793fc197e0d6a67f90b92bb /x11-plugins/wmdrawer
parentx11-plugins/wmcdplay: fix C++11 string literal (diff)
downloadgentoo-e55849e2f21b1d1b6cb0d08b59ec708093ca2da8.tar.gz
gentoo-e55849e2f21b1d1b6cb0d08b59ec708093ca2da8.tar.bz2
gentoo-e55849e2f21b1d1b6cb0d08b59ec708093ca2da8.zip
x11-plugins/wmdrawer: respect CC
Closes: https://bugs.gentoo.org/760591 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins/wmdrawer')
-rw-r--r--x11-plugins/wmdrawer/wmdrawer-0.10.5-r3.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/x11-plugins/wmdrawer/wmdrawer-0.10.5-r3.ebuild b/x11-plugins/wmdrawer/wmdrawer-0.10.5-r3.ebuild
index 8ed75478b444..d72e2c0e4a88 100644
--- a/x11-plugins/wmdrawer/wmdrawer-0.10.5-r3.ebuild
+++ b/x11-plugins/wmdrawer/wmdrawer-0.10.5-r3.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit toolchain-funcs
+
DESCRIPTION="dockapp which provides a drawer (retractable button bar) to launch applications"
HOMEPAGE="http://people.easter-eggs.org/~valos/wmdrawer/"
SRC_URI="http://people.easter-eggs.org/~valos/wmdrawer/${P}.tar.gz"
@@ -33,11 +35,11 @@ src_prepare() {
# Do not auto-strip binaries
sed -i -e 's/ strip $@//' Makefile || die
# Honour Gentoo LDFLAGS
- sed -i -e 's/$(CC) -o/$(CC) $(REAL_LDFLAGS) -o/' Makefile || die
+ sed -i -e 's/$(CC) -o/$(CC) $(GENTOO_LDFLAGS) -o/' Makefile || die
}
src_compile() {
- emake REAL_LDFLAGS="${LDFLAGS}"
+ emake CC="$(tc-getCC)" GENTOO_LDFLAGS="${LDFLAGS}"
}
src_install() {