summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-04-20 11:33:00 +0200
committerMarek Szuba <marecki@gentoo.org>2021-04-20 11:42:26 +0200
commit6d117a5f516289df25c66703b1a9620826078f0a (patch)
tree31a8e4589d96ed89195a2c7f9a3d2731187a6c51 /x11-plugins/pidgin-gnome-keyring/files
parentdev-libs/libgcrypt: Version bump (v1.9.3) (diff)
downloadgentoo-6d117a5f516289df25c66703b1a9620826078f0a.tar.gz
gentoo-6d117a5f516289df25c66703b1a9620826078f0a.tar.bz2
gentoo-6d117a5f516289df25c66703b1a9620826078f0a.zip
x11-plugins/pidgin-gnome-keyring: fix pkgconfig calls in the Makefile
For some reason upstream has opted to this as `pkg-config foo`, which as reported in Bug #784323 does not always (I still cannot reproduce it on my end) work as it should. Do it the proper Make way, i.e. with $(shell pkg-config foo). While at it, bump the package to EAPI 7. Closes: https://bugs.gentoo.org/784323 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'x11-plugins/pidgin-gnome-keyring/files')
-rw-r--r--x11-plugins/pidgin-gnome-keyring/files/pidgin-gnome-keyring-2.0-pkgconfig_dirs.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-gnome-keyring/files/pidgin-gnome-keyring-2.0-pkgconfig_dirs.patch b/x11-plugins/pidgin-gnome-keyring/files/pidgin-gnome-keyring-2.0-pkgconfig_dirs.patch
new file mode 100644
index 000000000000..4f33cee65318
--- /dev/null
+++ b/x11-plugins/pidgin-gnome-keyring/files/pidgin-gnome-keyring-2.0-pkgconfig_dirs.patch
@@ -0,0 +1,32 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,10 +1,11 @@
+ TARGET = gnome-keyring
+
+-SECRETFLAGS = `pkg-config --libs --cflags libsecret-1`
+-PURPLEFLAGS = `pkg-config --cflags purple`
+-VERSION = $(shell cat VERSION)
++SECRETFLAGS := $(shell pkg-config --libs --cflags libsecret-1)
++PURPLEFLAGS := $(shell pkg-config --cflags purple)
++PLUGINDIR := $(shell pkg-config --variable=plugindir purple)
++VERSION := $(shell cat VERSION)
+ ifeq ($(strip $(VERSION)),)
+- VERSION = `git describe --tags`
++ VERSION := $(shell git describe --tags)
+ endif
+
+ all: ${TARGET}.so
+@@ -15,11 +16,10 @@
+
+ ${TARGET}.so: ${TARGET}.c
+
+- ${CC} ${CFLAGS} ${LDFLAGS} -Wall -I. -g -O2 ${TARGET}.c -o ${TARGET}.so -shared -fPIC -DPIC -ggdb ${PURPLEFLAGS} ${SECRETFLAGS} -DVERSION=\"${VERSION}\"
++ ${CC} ${CFLAGS} ${LDFLAGS} -Wall -I. ${TARGET}.c -o ${TARGET}.so -shared -fPIC -DPIC ${PURPLEFLAGS} ${SECRETFLAGS} -DVERSION=\"${VERSION}\"
+
+ install: ${TARGET}.so
+- mkdir -p ${DESTDIR}/usr/lib/purple-2/
+- cp ${TARGET}.so ${DESTDIR}/usr/lib/purple-2/
++ install -D ${TARGET}.so ${DESTDIR}/$(PLUGINDIR)/${TARGET}.so
+
+ install_local: ${TARGET}.so
+ mkdir -p ~/.purple/plugins