summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-07-28 21:34:07 -0400
committerMatt Turner <mattst88@gentoo.org>2024-07-28 21:47:33 -0400
commitef5d077455bbdfa85e459fcc2ea298de1928fed7 (patch)
treecfd13ffcb512f60a2468559c1b31a8850bc3539f /x11-misc
parentdev-util/ruff: add 0.5.5 (diff)
downloadgentoo-ef5d077455bbdfa85e459fcc2ea298de1928fed7.tar.gz
gentoo-ef5d077455bbdfa85e459fcc2ea298de1928fed7.tar.bz2
gentoo-ef5d077455bbdfa85e459fcc2ea298de1928fed7.zip
x11-misc/compose-tables: Version bump to 1.8.10
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/compose-tables/Manifest1
-rw-r--r--x11-misc/compose-tables/compose-tables-1.8.10.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/x11-misc/compose-tables/Manifest b/x11-misc/compose-tables/Manifest
index 25b09129264c..3803f6c183ed 100644
--- a/x11-misc/compose-tables/Manifest
+++ b/x11-misc/compose-tables/Manifest
@@ -1 +1,2 @@
+DIST libX11-1.8.10.tar.xz 1839380 BLAKE2B 72ff400e1aad5bcb04e5dd3fb43f7767fad47e38cf628382cd5ffd5a204efc4de4f626027dddbbc7e10f80f8eaee0bcdf9792d9d012256366920f7ae0cffcb15 SHA512 f801f5b77cbc55074f73dc95b29fff7b5e1b13b99641f6e397788ad9f31a29793ed4e8e5bd373122c790ef90627e8f9d6d5e271051c1767a479a85c55cd82bc1
DIST libX11-1.8.9.tar.xz 1811900 BLAKE2B 8858157ac490d65e19500bfbb2ab773a3a30041f8a757ff22fff8fb0124044b8bb826f6dff4115230c757a175b61a3f7d596d976d98be760085749878d64f871 SHA512 737af91818537295ac86be601b1e3d7e37d150716ec549580913b7cc9a44fee7a6ce9dbc3d46167eed91f23fe857c4dd355ed8f8440fe5fbbf8e9ebe47091b96
diff --git a/x11-misc/compose-tables/compose-tables-1.8.10.ebuild b/x11-misc/compose-tables/compose-tables-1.8.10.ebuild
new file mode 100644
index 000000000000..ade5421accec
--- /dev/null
+++ b/x11-misc/compose-tables/compose-tables-1.8.10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_MULTILIB=no
+XORG_TARBALL_SUFFIX=xz
+inherit xorg-3
+
+# Note: please bump this with x11-libs/libX11
+DESCRIPTION="X.Org Compose Key tables from libX11"
+# xorg-3.eclass would attempt to fetch a tarball with a matching name to this package
+SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/lib/libX11-${PV}.tar.${XORG_TARBALL_SUFFIX}"
+S="${WORKDIR}/libX11-${PV}/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+# Only needed by configure
+DEPEND="
+ x11-base/xorg-proto
+ >=x11-libs/libxcb-1.11.1
+ x11-libs/xtrans"
+# RDEPEND=""
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --without-xmlto
+ --without-fop
+ --disable-specs
+ --disable-xkb
+ --with-keysymdefdir="${ESYSROOT}/usr/include/X11"
+ )
+ xorg-3_src_configure
+}
+
+src_compile() {
+ emake -C nls
+}
+
+src_test() {
+ :;
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C nls install
+}