summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-02-01 11:48:09 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-02-01 11:52:18 +0100
commit5ea62dcd197a12836eda130d2889993cf06dad30 (patch)
tree1077679ec4fdedbbbfeef9eaf207b36278b6d9ab /x11-misc
parentapp-backup/bareos: fix dependency (diff)
downloadgentoo-5ea62dcd197a12836eda130d2889993cf06dad30.tar.gz
gentoo-5ea62dcd197a12836eda130d2889993cf06dad30.tar.bz2
gentoo-5ea62dcd197a12836eda130d2889993cf06dad30.zip
x11-misc/rofi: add 1.7.3
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/rofi/Manifest1
-rw-r--r--x11-misc/rofi/rofi-1.7.3.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/x11-misc/rofi/Manifest b/x11-misc/rofi/Manifest
index 412bc352a099..38dc56c35eb8 100644
--- a/x11-misc/rofi/Manifest
+++ b/x11-misc/rofi/Manifest
@@ -1,3 +1,4 @@
DIST rofi-1.6.1.tar.gz 569262 BLAKE2B 938b45f8326b5a28e349ac9f7028c476274faa4f932a773acc350d5e1dc8d5c05c7cfb7ec10f1ab5d8c83590074424c3379768671d37ee799d78e508b8c4a4cb SHA512 b54e75818a98fa9262a3016260051837de189d49beff4f4a158cb2e7f41438641377e11d75c164f423e6a86d8b8fca3b76e2630611678525465d06c21b393f60
DIST rofi-1.7.0.tar.gz 902294 BLAKE2B 281f48702650f65e4b037fdbbe6861e173dd3465cf6a80a1d2038271511a9f85ebdb19d8e7a1854f82d52172bbfea6eb1b1685228fc4ff874773033406c9267b SHA512 84a42ecf519c7eed8093c4af3b66731b890939a2bf2a63290e599103705f6bacaba59ade1b8a1bc854f6b767e8d44ee42c20e44f63886bcacbfdbe0468d350b4
DIST rofi-1.7.2.tar.gz 921356 BLAKE2B 88daaac60f4deab18b9ca00cdd490c57aef7ba103ca947a25a204c4e1da9d5b5a3eb2af4e88cd0f0c920315ee30a49982f521fdd9fde2f5de99b061d52ca410b SHA512 5a3d2b118c0d74e6f9499709000e7d6de270d7c51abcc1a376ecd3838b159ff311cc171e8a1968d6872fcbb6deed565e7d777b687f49756c5ba85351f2f089ea
+DIST rofi-1.7.3.tar.gz 935184 BLAKE2B 66585b5542fcf59f22c68ad753a04051a188524c8008435f75b28f923cc46ecb9a0d41a98414577dc59b5a899488de77a6301544fc5af35a7d14a4d8ec930dad SHA512 5d1b8fed868a7fcf372298800997d4aeeb9b428858448a9b9e4c523af8d878aa172dc63ad788cdc950af89a1f3ea850bc4c98a55c9e8ace29e67050ac0c02078
diff --git a/x11-misc/rofi/rofi-1.7.3.ebuild b/x11-misc/rofi/rofi-1.7.3.ebuild
new file mode 100644
index 000000000000..7f2f90372111
--- /dev/null
+++ b/x11-misc/rofi/rofi-1.7.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://github.com/davatorium/rofi"
+SRC_URI="https://github.com/davatorium/rofi/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+drun test +windowmode"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+"
+RDEPEND="
+ dev-libs/glib:2
+ gnome-base/librsvg:2
+ media-libs/freetype
+ virtual/jpeg
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libxcb
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+ x11-misc/xkeyboard-config
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+ test? ( >=dev-libs/check-0.11 )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+
+ local myeconfargs=(
+ $(use_enable drun)
+ $(use_enable test check)
+ $(use_enable windowmode)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+pkg_postinst() {
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "${v}" -lt 1.7.0; then
+ elog "Rofi 1.7.0 removed the (deprecated) xresources based configuration setup."
+ elog "If you are still using old configuration setup, please convert it to new format manually."
+ elog "The new format configuration can be generated by 'rofi -dump-config > ~/.config/rofi/config.rasi'."
+ elog "For more information, please see https://github.com/davatorium/rofi/releases/tag/1.7.0"
+ fi
+ done
+}