summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xkbd/xkbd-0.8.16.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xkbd/xkbd-0.8.16.ebuild')
-rw-r--r--x11-misc/xkbd/xkbd-0.8.16.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/x11-misc/xkbd/xkbd-0.8.16.ebuild b/x11-misc/xkbd/xkbd-0.8.16.ebuild
new file mode 100644
index 000000000000..ad0a25f89a43
--- /dev/null
+++ b/x11-misc/xkbd/xkbd-0.8.16.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="onscreen soft keyboard for X11"
+HOMEPAGE="http://trac.hackable1.org/trac/wiki/Xkbd"
+SRC_URI="http://trac.hackable1.org/trac/raw-attachment/wiki/Xkbd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="doc debug"
+
+RDEPEND="x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXtst
+ x11-libs/libXpm
+ media-libs/freetype
+ dev-libs/expat
+ sys-libs/zlib
+ doc? ( app-text/docbook-sgml-utils )"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+src_prepare() {
+ # 2008-03-23 gi1242: Fix handling of -geometry argument
+ epatch "${FILESDIR}"/${P}-fix-geometry.patch
+ # 2008-03-23 gi1242: Increase default repeat delay
+ epatch "${FILESDIR}"/${PN}-0.8.15-increase-delay.patch
+ epatch "${FILESDIR}"/${PN}-0.8.15-fix-keysyms-search.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug)
+}
+
+src_compile() {
+ default
+
+ use doc && docbook2html README
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html
+ doins *.html
+ fi
+}