summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-05 00:07:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-05 00:08:09 +0200
commit244fb24df651a343a30422f035432fc8aa14895e (patch)
tree1e2e27c0c8305911494619086c3bf97414bfc7f5 /x11-misc/slop
parentmedia-gfx/imagemagick: don't pull in inkscape (diff)
downloadgentoo-244fb24df651a343a30422f035432fc8aa14895e.tar.gz
gentoo-244fb24df651a343a30422f035432fc8aa14895e.tar.bz2
gentoo-244fb24df651a343a30422f035432fc8aa14895e.zip
x11-misc/slop: 7.5 version bump
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-misc/slop')
-rw-r--r--x11-misc/slop/Manifest1
-rw-r--r--x11-misc/slop/slop-7.5.ebuild43
-rw-r--r--x11-misc/slop/slop-9999.ebuild4
3 files changed, 47 insertions, 1 deletions
diff --git a/x11-misc/slop/Manifest b/x11-misc/slop/Manifest
index dde7b8e91c76..6ea0008d7887 100644
--- a/x11-misc/slop/Manifest
+++ b/x11-misc/slop/Manifest
@@ -1 +1,2 @@
DIST slop-7.4.tar.gz 50079 BLAKE2B 20815270bf1bffe0ef26630fd31d0d4cc7261633cef389e64c232a89033b6e8b5e1651fb5c882e2870808107734c4c088123b85675fa2aae932570d770344dc8 SHA512 13d09c2c9f05760ee0a273edb6d40da8a87989d3f071a8c868a0c7e535ba89b9eb934c79d56212cd689687f86e3683cef1b749ef7b37be3805ea8eb05c796e58
+DIST slop-7.5.tar.gz 51060 BLAKE2B 8d0fcf932181dfc482be7c54cf5a08605a32c85bcd8b27223a4cd8a08323382e802a7f20faa6c51fe67583b1d320cf783c7b5cc8b871e534ea11a32b827e1f45 SHA512 c02e40c5b924841996617fcc9629a6a739a04b6128c18e1eb06dc285d2f8026d847e67077fb59a111fc45c112f871a6e5faef20108c3d777271e1d4aca7f4737
diff --git a/x11-misc/slop/slop-7.5.ebuild b/x11-misc/slop/slop-7.5.ebuild
new file mode 100644
index 000000000000..a9c376b256ec
--- /dev/null
+++ b/x11-misc/slop/slop-7.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Application that queries the user for a selection for printing"
+HOMEPAGE="https://github.com/naelstrof/slop"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/naelstrof/slop.git"
+else
+ SRC_URI="https://github.com/naelstrof/slop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+IUSE="opengl"
+
+RDEPEND="
+ dev-libs/icu:=
+ x11-libs/libX11
+ x11-libs/libXext
+ opengl? (
+ media-libs/glew:0=
+ media-libs/libglvnd
+ virtual/opengl
+ x11-libs/libXrender:=
+ )
+"
+DEPEND="${RDEPEND}
+ media-libs/glm
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSLOP_OPENGL=$(usex opengl)
+ )
+ cmake_src_configure
+}
diff --git a/x11-misc/slop/slop-9999.ebuild b/x11-misc/slop/slop-9999.ebuild
index afc048826632..a9c376b256ec 100644
--- a/x11-misc/slop/slop-9999.ebuild
+++ b/x11-misc/slop/slop-9999.ebuild
@@ -26,9 +26,11 @@ RDEPEND="
x11-libs/libXext
opengl? (
media-libs/glew:0=
+ media-libs/libglvnd
virtual/opengl
x11-libs/libXrender:=
- )"
+ )
+"
DEPEND="${RDEPEND}
media-libs/glm
"