summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-15 13:09:48 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-15 15:17:29 +0200
commitd92c7fe7187262c5a16b02612c03ee9b94a21de0 (patch)
treebe703a408ffdb4fb93ed4a5df77bbbf7e028b937 /x11-misc/qt5ct
parentdev-python/cython: Improve py39 patch to avoid breaking py27 (diff)
downloadgentoo-d92c7fe7187262c5a16b02612c03ee9b94a21de0.tar.gz
gentoo-d92c7fe7187262c5a16b02612c03ee9b94a21de0.tar.bz2
gentoo-d92c7fe7187262c5a16b02612c03ee9b94a21de0.zip
x11-misc/qt5ct: Bump to 1.0
Closes: https://bugs.gentoo.org/728184 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'x11-misc/qt5ct')
-rw-r--r--x11-misc/qt5ct/Manifest1
-rw-r--r--x11-misc/qt5ct/qt5ct-1.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/x11-misc/qt5ct/Manifest b/x11-misc/qt5ct/Manifest
index 3d94c4a497a0..3b14ed92043e 100644
--- a/x11-misc/qt5ct/Manifest
+++ b/x11-misc/qt5ct/Manifest
@@ -1 +1,2 @@
DIST qt5ct-0.41.tar.bz2 73009 BLAKE2B de6360feb16a82b262c13e6a3cbe226b7be7c3e95b1f1262b3802de59fc3bb8820c935b170a15a88e80164e6167f6259777c65fda6a3f8fbf1d115a63ddcc1f2 SHA512 a94f9996dc2198d3c8c9af8610912d12b915b8c547a49c36f7bc083b6f237b318d7903e91fb6fcfe06996a319c361104c1923e6d0c49446b6fb66a1e44fae009
+DIST qt5ct-1.0.tar.bz2 73360 BLAKE2B a2a37534434102f08d0f225017c5b835bc22ac2d86592505d4dcc8823a8ed34fd54085a581e86e83ecaec04141e90f4c6e87b9aaed027b68e29ed9a773108263 SHA512 f650362c90782128e1b3ddb61e73d0295bc5b108a75c8a10d085ce9df7dc0926ac40baf80705136b39cc779212fc97e121757c440f2728aab12b761caace78b2
diff --git a/x11-misc/qt5ct/qt5ct-1.0.ebuild b/x11-misc/qt5ct/qt5ct-1.0.ebuild
new file mode 100644
index 000000000000..9f615edb3db0
--- /dev/null
+++ b/x11-misc/qt5ct/qt5ct-1.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="Qt5 configuration tool, similar to qtconfig for Qt4"
+HOMEPAGE="https://sourceforge.net/projects/qt5ct/"
+SRC_URI="https://download.sourceforge.net/qt5ct/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+dbus"
+
+RDEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ dbus? (
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5[dbus]
+ )
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+src_configure() {
+ eqmake5 DISABLE_DBUS=$(usex dbus 0 1)
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+
+ newenvd - 98qt5ct <<< 'QT_QPA_PLATFORMTHEME=qt5ct'
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ ewarn "qt5ct configuration won't be applied to the currently running sessions."
+ ewarn "Please relogin."
+ fi
+ if ! has_version 'dev-qt/qtsvg:5'; then
+ elog
+ elog "For SVG icon themes, please install 'dev-qt/qtsvg:5'."
+ elog
+ fi
+}