summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-06-22 16:02:06 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-08 09:52:32 +0200
commit237dda550d1310aaeafc27f98d48b618460625a8 (patch)
tree8a1968a28c4b630d3b72e84dfbb3cf96e9d5941b /x11-misc/bbweather
parentx11-misc/bbweather: use HTTPs (diff)
downloadgentoo-237dda550d1310aaeafc27f98d48b618460625a8.tar.gz
gentoo-237dda550d1310aaeafc27f98d48b618460625a8.tar.bz2
gentoo-237dda550d1310aaeafc27f98d48b618460625a8.zip
x11-misc/bbweather: EAPI7, improve ebuild
Diffstat (limited to 'x11-misc/bbweather')
-rw-r--r--x11-misc/bbweather/bbweather-0.6.3-r2.ebuild46
-rw-r--r--x11-misc/bbweather/files/bbweather-asneeded.patch8
2 files changed, 50 insertions, 4 deletions
diff --git a/x11-misc/bbweather/bbweather-0.6.3-r2.ebuild b/x11-misc/bbweather/bbweather-0.6.3-r2.ebuild
new file mode 100644
index 000000000000..1de14db362e4
--- /dev/null
+++ b/x11-misc/bbweather/bbweather-0.6.3-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="blackbox weather monitor"
+HOMEPAGE="https://www.netmeister.org/apps/bbweather/"
+SRC_URI="https://www.netmeister.org/apps/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ x11-libs/libX11"
+RDEPEND="${DEPEND}
+ net-misc/wget
+ x11-apps/xmessage
+ !<=x11-plugins/gkrellweather-2.0.7-r1"
+
+PATCHES=( "${FILESDIR}"/${PN}-asneeded.patch )
+
+src_prepare() {
+ default
+ gunzip doc/*.gz || die
+ sed -i \
+ -e "s:man_DATA:man1_MANS:;s:.gz::g;/^mandir/d" \
+ doc/Makefile.am || die
+ sed -i \
+ -e 's|-helvetica-|-*-|g' \
+ resource.cpp data/${PN}.{nobb,style} || die
+ eautoreconf
+}
+
+src_install () {
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install
+ dodoc README AUTHORS ChangeLog NEWS TODO data/README.bbweather
+
+ # since multiple bbtools packages provide this file, install
+ # it in /usr/share/doc/${PF}
+ mv "${D}"/usr/share/bbtools/bbtoolsrc.in \
+ "${D}"/usr/share/doc/${PF}/bbtoolsrc.example || die
+}
diff --git a/x11-misc/bbweather/files/bbweather-asneeded.patch b/x11-misc/bbweather/files/bbweather-asneeded.patch
index 593e471641c8..001ac112720f 100644
--- a/x11-misc/bbweather/files/bbweather-asneeded.patch
+++ b/x11-misc/bbweather/files/bbweather-asneeded.patch
@@ -2,8 +2,8 @@ Fixing build with as-needed
https://bugs.gentoo.org/248556
---- configure.in
-+++ configure.in
+--- a/configure.in
++++ b/configure.in
@@ -56,15 +56,10 @@
AC_PATH_X
AC_PATH_XTRA
@@ -22,8 +22,8 @@ https://bugs.gentoo.org/248556
dnl Checks for header files.
AC_HEADER_STDC
---- Makefile.am
-+++ Makefile.am
+--- a/Makefile.am
++++ b/Makefile.am
@@ -1,5 +1,4 @@
-CPPFLAGS = @CPPFLAGS@ \
- -DDEFAULT_CONF=\"$(datadir)/bbtools/bbweather.conf\" \