summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-02-06 09:41:48 +0200
committerDavid Seifert <soap@gentoo.org>2017-02-06 23:46:03 +0100
commit5db653685d01e9b9bdfc4fb81e9a2973d394e6ee (patch)
tree1bd6519c1bf7aef763e61f37fa804da95c8533d4 /x11-misc/apwal
parentmedia-fonts/dina: Bump to 2.93 Gentoo bug: https://bugs.gentoo.org/567276 (diff)
downloadgentoo-5db653685d01e9b9bdfc4fb81e9a2973d394e6ee.tar.gz
gentoo-5db653685d01e9b9bdfc4fb81e9a2973d394e6ee.tar.bz2
gentoo-5db653685d01e9b9bdfc4fb81e9a2973d394e6ee.zip
x11-misc/apwal: EAPI bump 2 -> 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3837
Diffstat (limited to 'x11-misc/apwal')
-rw-r--r--x11-misc/apwal/apwal-0.4.5-r2.ebuild30
-rw-r--r--x11-misc/apwal/files/apwal-0.4.5-makefile.patch8
2 files changed, 34 insertions, 4 deletions
diff --git a/x11-misc/apwal/apwal-0.4.5-r2.ebuild b/x11-misc/apwal/apwal-0.4.5-r2.ebuild
new file mode 100644
index 000000000000..59e3ef5000a2
--- /dev/null
+++ b/x11-misc/apwal/apwal-0.4.5-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A simple application launcher and combined editor"
+HOMEPAGE="http://apwal.free.fr/"
+SRC_URI="http://apwal.free.fr/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/gdk-pixbuf
+ dev-libs/libxml2
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+S=${WORKDIR}/${PN}
+
+src_configure() {
+ tc-export CC
+}
diff --git a/x11-misc/apwal/files/apwal-0.4.5-makefile.patch b/x11-misc/apwal/files/apwal-0.4.5-makefile.patch
index 462ba882d8e3..2c278b278a03 100644
--- a/x11-misc/apwal/files/apwal-0.4.5-makefile.patch
+++ b/x11-misc/apwal/files/apwal-0.4.5-makefile.patch
@@ -3,8 +3,8 @@
* don't strip binaries
* fix install paths
---- Makefile
-+++ Makefile
+--- a/Makefile
++++ b/Makefile
@@ -1,11 +1,8 @@
include Makefile.inc
@@ -19,8 +19,8 @@
clean:
(cd src && $(MAKE) $@)
---- src/Makefile
-+++ src/Makefile
+--- a/src/Makefile
++++ b/src/Makefile
@@ -5,8 +5,8 @@
CFLAGS=-g -Wall -Werror `pkg-config --cflags gtk+-2.0 gthread-2.0` -DGTK_DISABLE_DEPRECATED -DAPWAL_DEBUG
LDFLAGS=`pkg-config --libs gtk+-2.0 gthread-2.0` `xml2-config --libs`