summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-11-15 23:20:37 +0100
committerJeroen Roovers <jer@gentoo.org>2019-11-15 23:21:11 +0100
commit2abc8d0bb878cfa6804571de88b8b0c28e79fb99 (patch)
tree5264c28e2211d281c1c7ca8b6053a36ddc9318b8 /x11-libs/fltk
parentx86/package.use.mask: dev-php/pecl-mongodb[test] (diff)
downloadgentoo-2abc8d0bb878cfa6804571de88b8b0c28e79fb99.tar.gz
gentoo-2abc8d0bb878cfa6804571de88b8b0c28e79fb99.tar.bz2
gentoo-2abc8d0bb878cfa6804571de88b8b0c28e79fb99.zip
x11-libs/fltk: Maybe fix FLTK_INCLUDE_DIRS in cmake files
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Bug: https://bugs.gentoo.org/show_bug.cgi?id=462776 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-libs/fltk')
-rw-r--r--x11-libs/fltk/files/fltk-1.3.5-cmake.patch33
-rw-r--r--x11-libs/fltk/files/fltk-1.3.5-optim.patch11
-rw-r--r--x11-libs/fltk/fltk-1.3.5-r4.ebuild (renamed from x11-libs/fltk/fltk-1.3.5-r3.ebuild)6
-rw-r--r--x11-libs/fltk/fltk-1.3.9999.ebuild6
-rw-r--r--x11-libs/fltk/fltk-1.4.9999.ebuild6
5 files changed, 50 insertions, 12 deletions
diff --git a/x11-libs/fltk/files/fltk-1.3.5-cmake.patch b/x11-libs/fltk/files/fltk-1.3.5-cmake.patch
new file mode 100644
index 000000000000..1eac250248d2
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.3.5-cmake.patch
@@ -0,0 +1,33 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -57,6 +57,7 @@
+ FL_DSO_VERSION=${FL_MAJOR_VERSION}.${FL_MINOR_VERSION}
+ FL_ABI_VERSION=${FL_MAJOR_VERSION}.${FL_MINOR_VERSION}.0
+ FL_VERSION=${FL_MAJOR_VERSION}.${FL_MINOR_VERSION}.${FL_PATCH_VERSION}
++FLTK_VERSION_FULL=${FL_VERSION}
+
+ AC_SUBST(FL_MAJOR_VERSION)
+ AC_SUBST(FL_MINOR_VERSION)
+@@ -64,6 +65,7 @@
+ AC_SUBST(FL_DSO_VERSION)
+ AC_SUBST(FL_ABI_VERSION)
+ AC_SUBST(FL_VERSION)
++AC_SUBST(FLTK_VERSION_FULL)
+
+ AC_SUBST(ARCHFLAGS)
+ AC_SUBST(OPTIM)
+@@ -1576,10 +1578,13 @@
+ BINARY_DIR=
+ AC_SUBST(BINARY_DIR)
+
++INCLUDE_DIRS="${includedir}"
++AC_SUBST(INCLUDE_DIRS)
++
+ dnl Write all of the files...
+ AC_CONFIG_HEADER(config.h:configh.in)
+ AC_CONFIG_HEADER(FL/abi-version.h:abi-version.in)
+-AC_CONFIG_FILES([makeinclude fltk.list fltk-config fltk.spec FL/Makefile])
++AC_CONFIG_FILES([makeinclude fltk.list fltk-config fltk.spec FL/Makefile CMake/FLTKConfig.cmake])
+ AC_OUTPUT
+
+ dnl Make sure the fltk-config script is executable...
diff --git a/x11-libs/fltk/files/fltk-1.3.5-optim.patch b/x11-libs/fltk/files/fltk-1.3.5-optim.patch
new file mode 100644
index 000000000000..4d1512d749dd
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.3.5-optim.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1265,7 +1265,7 @@
+ if test "x$with_optim" != x; then
+ OPTIM="$with_optim $OPTIM"
+ else
+- OPTIM="-Os $OPTIM"
++ OPTIM=" $OPTIM"
+ fi
+ fi
+
diff --git a/x11-libs/fltk/fltk-1.3.5-r3.ebuild b/x11-libs/fltk/fltk-1.3.5-r4.ebuild
index f7f98303c4b6..7af2106929bc 100644
--- a/x11-libs/fltk/fltk-1.3.5-r3.ebuild
+++ b/x11-libs/fltk/fltk-1.3.5-r4.ebuild
@@ -63,6 +63,8 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.3.3-makefile-dirs.patch
"${FILESDIR}"/${PN}-1.3.3-visibility.patch
"${FILESDIR}"/${PN}-1.3.4-conf-tests.patch
+ "${FILESDIR}"/${PN}-1.3.5-cmake.patch
+ "${FILESDIR}"/${PN}-1.3.5-optim.patch
)
src_prepare() {
@@ -77,10 +79,6 @@ src_prepare() {
-e "/^docdir/s:fltk:${PF}/html:" \
-e "/SILENT:/d" \
makeinclude.in || die
- sed -e "s/7/${PV}/" \
- < "${FILESDIR}"/FLTKConfig.cmake \
- > CMake/FLTKConfig.cmake || die
- sed -e 's:-Os::g' -i configure.ac || die
# also in Makefile:config.guess config.sub:
cp misc/config.{guess,sub} . || die
diff --git a/x11-libs/fltk/fltk-1.3.9999.ebuild b/x11-libs/fltk/fltk-1.3.9999.ebuild
index 66dbf39fd1a9..f8b095c4b45d 100644
--- a/x11-libs/fltk/fltk-1.3.9999.ebuild
+++ b/x11-libs/fltk/fltk-1.3.9999.ebuild
@@ -63,6 +63,8 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.3.9999-conf-tests.patch
"${FILESDIR}"/${PN}-1.3.3-makefile-dirs.patch
"${FILESDIR}"/${PN}-1.3.3-visibility.patch
+ "${FILESDIR}"/${PN}-1.3.5-cmake.patch
+ "${FILESDIR}"/${PN}-1.3.5-optim.patch
)
pkg_setup() {
@@ -87,10 +89,6 @@ src_prepare() {
-e "/^docdir/s:fltk:${PF}/html:" \
-e "/SILENT:/d" \
makeinclude.in || die
- sed -e "s/7/${PV}/" \
- < "${FILESDIR}"/FLTKConfig.cmake \
- > CMake/FLTKConfig.cmake || die
- sed -e 's:-Os::g' -i configure.ac || die
# also in Makefile:config.guess config.sub:
cp misc/config.{guess,sub} . || die
diff --git a/x11-libs/fltk/fltk-1.4.9999.ebuild b/x11-libs/fltk/fltk-1.4.9999.ebuild
index d18d64075f19..7940dc7b3efe 100644
--- a/x11-libs/fltk/fltk-1.4.9999.ebuild
+++ b/x11-libs/fltk/fltk-1.4.9999.ebuild
@@ -67,6 +67,8 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.3.0-share.patch
"${FILESDIR}"/${PN}-1.3.3-makefile-dirs.patch
"${FILESDIR}"/${PN}-1.3.4-conf-tests.patch
+ "${FILESDIR}"/${PN}-1.3.5-cmake.patch
+ "${FILESDIR}"/${PN}-1.3.5-optim.patch
)
pkg_setup() {
@@ -91,10 +93,6 @@ src_prepare() {
-e "/^docdir/s:fltk:${PF}/html:" \
-e "/SILENT:/d" \
makeinclude.in || die
- sed -e "s/7/${PV}/" \
- < "${FILESDIR}"/FLTKConfig.cmake \
- > CMake/FLTKConfig.cmake || die
- sed -e 's:-Os::g' -i configure.ac || die
# also in Makefile:config.guess config.sub:
cp misc/config.{guess,sub} . || die