summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/flowcanvas
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/flowcanvas')
-rw-r--r--x11-libs/flowcanvas/Manifest1
-rw-r--r--x11-libs/flowcanvas/files/gv234.patch48
-rw-r--r--x11-libs/flowcanvas/files/ldconfig2.patch10
-rw-r--r--x11-libs/flowcanvas/flowcanvas-0.7.1-r1.ebuild42
-rw-r--r--x11-libs/flowcanvas/metadata.xml10
5 files changed, 111 insertions, 0 deletions
diff --git a/x11-libs/flowcanvas/Manifest b/x11-libs/flowcanvas/Manifest
new file mode 100644
index 000000000000..f26ba4ccf853
--- /dev/null
+++ b/x11-libs/flowcanvas/Manifest
@@ -0,0 +1 @@
+DIST flowcanvas-0.7.1.tar.bz2 139471 SHA256 047928d858fd1e9296a9984de7468c86bbe23fc42e286691b8f273541402c596 SHA512 e9c7ee9693c6b78e44a0611a8d73c1b7ffa1ae0f3e36c9b0bbc88d5a293c3e5183c17e14b2079d611c988f30cb292caee52ab37f8a13da96b5c8c8261e408410 WHIRLPOOL 97ecfcd3131c5f931d57ff2c5a396971839513cd4ec0ef0d2e83c8e27be79bbde7385f07cd231199656128c4c319e9e52788486b2f539ca74b5033c1233b6476
diff --git a/x11-libs/flowcanvas/files/gv234.patch b/x11-libs/flowcanvas/files/gv234.patch
new file mode 100644
index 000000000000..ec03696135c0
--- /dev/null
+++ b/x11-libs/flowcanvas/files/gv234.patch
@@ -0,0 +1,48 @@
+Index: flowcanvas-0.7.1/src/Canvas.cpp
+===================================================================
+--- flowcanvas-0.7.1.orig/src/Canvas.cpp
++++ flowcanvas-0.7.1/src/Canvas.cpp
+@@ -1253,21 +1253,21 @@ Canvas::layout_dot(bool use_length_hints
+ */
+
+ GVC_t* gvc = gvContext();
+- Agraph_t* G = agopen((char*)"g", AGDIGRAPH);
++ Agraph_t* G = agopen((char*)"g", Agdirected, 0);
+
+ nodes.gvc = gvc;
+ nodes.G = G;
+
+ if (_direction == HORIZONTAL)
+- agraphattr(G, (char*)"rankdir", (char*)"LR");
++ agattr(G, AGRAPH, (char*)"rankdir", (char*)"LR");
+ else
+- agraphattr(G, (char*)"rankdir", (char*)"TD");
++ agattr(G, AGRAPH, (char*)"rankdir", (char*)"TD");
+
+ unsigned id = 0;
+ for (ItemList::const_iterator i = _items.begin(); i != _items.end(); ++i) {
+ std::ostringstream ss;
+ ss << "n" << id++;
+- Agnode_t* node = agnode(G, strdup(ss.str().c_str()));
++ Agnode_t* node = agnode(G, strdup(ss.str().c_str()), 1);
+ if (boost::dynamic_pointer_cast<Module>(*i)) {
+ ss.str("");
+ ss << (*i)->width() / 96.0;
+@@ -1310,7 +1310,7 @@ Canvas::layout_dot(bool use_length_hints
+
+ assert(src_node && dst_node);
+
+- Agedge_t* edge = agedge(G, src_node, dst_node);
++ Agedge_t* edge = agedge(G, src_node, dst_node, NULL, 1);
+
+ if (use_length_hints && c->length_hint() != 0) {
+ std::ostringstream len_ss;
+@@ -1325,7 +1325,7 @@ Canvas::layout_dot(bool use_length_hints
+ if (partner) {
+ GVNodes::iterator p = nodes.find(partner);
+ if (p != nodes.end())
+- agedge(G, i->second, p->second);
++ agedge(G, i->second, p->second, NULL, 1);
+ }
+ }
+
diff --git a/x11-libs/flowcanvas/files/ldconfig2.patch b/x11-libs/flowcanvas/files/ldconfig2.patch
new file mode 100644
index 000000000000..d86e65eaf179
--- /dev/null
+++ b/x11-libs/flowcanvas/files/ldconfig2.patch
@@ -0,0 +1,10 @@
+Index: flowcanvas-0.7.1/wscript
+===================================================================
+--- flowcanvas-0.7.1.orig/wscript
++++ flowcanvas-0.7.1/wscript
+@@ -85,5 +85,3 @@ def build(bld):
+
+ # Documentation
+ autowaf.build_dox(bld, 'FLOWCANVAS', FLOWCANVAS_VERSION, top, out)
+-
+- bld.add_post_fun(autowaf.run_ldconfig)
diff --git a/x11-libs/flowcanvas/flowcanvas-0.7.1-r1.ebuild b/x11-libs/flowcanvas/flowcanvas-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..df8bbe8aca76
--- /dev/null
+++ b/x11-libs/flowcanvas/flowcanvas-0.7.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit waf-utils python-any-r1 eutils
+
+DESCRIPTION="Gtkmm/Gnomecanvasmm widget for boxes and lines environments"
+HOMEPAGE="http://wiki.drobilla.net/FlowCanvas"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug doc"
+
+RDEPEND="dev-libs/boost
+ >=dev-cpp/gtkmm-2.4:2.4
+ >=dev-cpp/libgnomecanvasmm-2.6:2.6
+ media-gfx/graphviz"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+DOCS=( AUTHORS README ChangeLog )
+
+src_prepare() {
+ epatch "${FILESDIR}/ldconfig2.patch"
+ has_version '>=media-gfx/graphviz-2.34' && epatch "${FILESDIR}/gv234.patch"
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --htmldir=/usr/share/doc/${PF}/html \
+ $(use debug && echo "--debug") \
+ $(use doc && echo "--doc")
+}
diff --git a/x11-libs/flowcanvas/metadata.xml b/x11-libs/flowcanvas/metadata.xml
new file mode 100644
index 000000000000..6292b8c1f28d
--- /dev/null
+++ b/x11-libs/flowcanvas/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proaudio</herd>
+<longdescription lang="en">
+ FlowCanvas is an interactive Gtkmm/Gnomecanvasmm widget for "boxes and
+ lines" environments (ie modular synths or interactive finite state automata
+ diagrams).
+</longdescription>
+</pkgmetadata>