summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-04-30 19:20:32 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-04-30 19:21:32 +0300
commit6f291d413a5ed241f8d5236038e1c456efe0f069 (patch)
tree10bff8f98220d801afe5d5281ac6f41d1af48c57 /www-servers
parentwww-client/chromium: require clang-16 (diff)
downloadgentoo-6f291d413a5ed241f8d5236038e1c456efe0f069.tar.gz
gentoo-6f291d413a5ed241f8d5236038e1c456efe0f069.tar.bz2
gentoo-6f291d413a5ed241f8d5236038e1c456efe0f069.zip
www-servers/civetweb: add 1.16
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/civetweb/Manifest1
-rw-r--r--www-servers/civetweb/civetweb-1.16.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/www-servers/civetweb/Manifest b/www-servers/civetweb/Manifest
index da62a017d55e..bd365934dc8c 100644
--- a/www-servers/civetweb/Manifest
+++ b/www-servers/civetweb/Manifest
@@ -1 +1,2 @@
DIST civetweb-1.12.tar.gz 11463079 BLAKE2B 1182f798a2f9cdb34754b3c0edf80160efda31f72d800b26b27ec36ff4a5623745495a52632a128aefda67c6b902250c4e01ec7debd73d4a95abfc42a1b17ea6 SHA512 d6f8d29011bc1accd5384856bef16c0f20305f622a8f8c127cdf3ae5c567db3aba0d76293cc8c77f90f4989c44b2896a45e533d2f2408cc49488d1d234d308f5
+DIST civetweb-1.16.tar.gz 12094780 BLAKE2B 7c2e094f6e4730459082c8557925f51775beb0b07fa01291f7a46bf3ea69d7f879566e71a8c6d5b9ad1b3b28d910d99e587eccc703e8b2d3d5797f589c24074a SHA512 a0b943dfc76d7fd47f5a7d2c834fd38ddd4cf01a11730cf2f7cfaf32fea9698f59672f3a0f86ac80e0abc315d94d2367a500d37013f305c87d45e84cf39ca816
diff --git a/www-servers/civetweb/civetweb-1.16.ebuild b/www-servers/civetweb/civetweb-1.16.ebuild
new file mode 100644
index 000000000000..83bd33185971
--- /dev/null
+++ b/www-servers/civetweb/civetweb-1.16.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+HOMEPAGE="https://github.com/civetweb/civetweb/"
+DESCRIPTION="Embedded C/C++ web server"
+SRC_URI="https://github.com/civetweb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="cxx +server ssl"
+
+DEPEND="ssl? ( dev-libs/openssl:0= )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=OFF
+ -DBUILD_SHARED_LIBS=ON
+ -DCIVETWEB_BUILD_TESTING=OFF
+ -DCIVETWEB_ENABLE_LUA=OFF
+ -DCIVETWEB_ENABLE_DUKTAPE=OFF
+ -DCIVETWEB_ENABLE_WEBSOCKETS=ON
+ -DCIVETWEB_ENABLE_CXX="$(usex cxx)"
+ -DCIVETWEB_ENABLE_SERVER_EXECUTABLE="$(usex server)"
+ -DCIVETWEB_ENABLE_SSL="$(usex ssl)"
+ )
+
+ cmake_src_configure
+}