summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2022-12-15 11:42:38 -0500
committerMike Pagano <mpagano@gentoo.org>2022-12-15 11:42:38 -0500
commit3d9a4ab3d3e3b5ed07e915549d9a69d299f32104 (patch)
tree87f626708b13a29bbed3b1251b7519bfbc889aa7 /www-servers
parentsys-cluster/kube-scheduler: drop 1.25.3 (diff)
downloadgentoo-3d9a4ab3d3e3b5ed07e915549d9a69d299f32104.tar.gz
gentoo-3d9a4ab3d3e3b5ed07e915549d9a69d299f32104.tar.bz2
gentoo-3d9a4ab3d3e3b5ed07e915549d9a69d299f32104.zip
www-servers/nginx-unit: add 1.29.0
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx-unit/Manifest1
-rw-r--r--www-servers/nginx-unit/nginx-unit-1.29.0.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/www-servers/nginx-unit/Manifest b/www-servers/nginx-unit/Manifest
index e9d04be7e3e6..5458d08b4966 100644
--- a/www-servers/nginx-unit/Manifest
+++ b/www-servers/nginx-unit/Manifest
@@ -1 +1,2 @@
DIST nginx-unit-1.28.0.tar.gz 878878 BLAKE2B 91906e342e3fc1154c781481110a8e5496a74da010b2c0618c7c27d63cf0926d94f17fd6206d7868e9ad39f0fbbb476fb3410d46b4b7935e942653d8328af840 SHA512 7d2033be3d8e9d15db21b5431348be73a10fbc19bcab7e83d3c5a770e11e23a53967afe051ec53e236896ac9e021d9146501bc32b87254f9b25778b4bc5d1cbe
+DIST nginx-unit-1.29.0.tar.gz 903909 BLAKE2B d9e2544ce7ffb4f9a510afaef2ddbf54a4482558d0cd3dd526c1371413e32fc72e848c95d3866928c1accc19bc2aecdb4c26b6907bfa57c382db53cc2f9fad3e SHA512 6b0a6718be5c3312f5e17fc39ae35ca849049c97d29c63a7effda7f994274af29eed88970389bb3010a2103c431e69920c951de5004853004d1aa604d868bd9f
diff --git a/www-servers/nginx-unit/nginx-unit-1.29.0.ebuild b/www-servers/nginx-unit/nginx-unit-1.29.0.ebuild
new file mode 100644
index 000000000000..c72136b53615
--- /dev/null
+++ b/www-servers/nginx-unit/nginx-unit-1.29.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit flag-o-matic python-single-r1 systemd toolchain-funcs
+
+MY_P="unit-${PV}"
+DESCRIPTION="Dynamic web and application server"
+HOMEPAGE="https://unit.nginx.org"
+SRC_URI="https://unit.nginx.org/download/${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+MY_USE="perl python ruby"
+MY_USE_PHP="php7-4 php8-0 php8-1 "
+IUSE="${MY_USE} ${MY_USE_PHP} ssl"
+REQUIRED_USE="|| ( ${IUSE} )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="perl? ( dev-lang/perl:= )
+ php7-4? ( dev-lang/php:7.4[embed] )
+ php8-0? ( dev-lang/php:8.0[embed] )
+ php8-1? ( dev-lang/php:8.1[embed] )
+ python? ( ${PYTHON_DEPS} )
+ ruby? (
+ dev-lang/ruby:=
+ dev-ruby/rubygems:=
+ )
+ ssl? ( dev-libs/openssl:0= )
+ virtual/libcrypt:0="
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ eapply_user
+ sed -i '/^CFLAGS/d' auto/make || die
+ default
+}
+
+src_configure() {
+ local opt=(
+ --control=unix:/run/${PN}.sock
+ --log=/var/log/${PN}
+ --modules=$(get_libdir)/${PN}
+ --pid=/run/${PN}.pid
+ --prefix=/usr
+ --state=/var/lib/${PN}
+ )
+
+ use ssl && opt+=( --openssl )
+ export AR="$(tc-getAR)"
+ export CC="$(tc-getCC)"
+ ./configure ${opt[@]} --ld-opt="${LDFLAGS}" || die "Core configuration failed"
+
+ # Modules require position-independent code
+ append-cflags $(test-flags-CC -fPIC)
+
+ for flag in ${MY_USE} ; do
+ if use ${flag} ; then
+ ./configure ${flag} || die "Module configuration failed: ${flag}"
+ fi
+ done
+
+ for flag in ${MY_USE_PHP} ; do
+ if use ${flag} ; then
+ local php_slot="/usr/$(get_libdir)/${flag/-/.}"
+ ./configure php \
+ --module=${flag} \
+ --config=${php_slot}/bin/php-config \
+ --lib-path=${php_slot}/$(get_libdir) || die "Module configuration failed: ${flag}"
+ fi
+ done
+}
+
+src_install() {
+ default
+
+ diropts -m 0770
+ keepdir /var/lib/${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ systemd_newunit "${FILESDIR}"/${PN}.service ${PN}.service
+}