summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-plugins/freshplayerplugin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-plugins/freshplayerplugin')
-rw-r--r--www-plugins/freshplayerplugin/Manifest1
-rw-r--r--www-plugins/freshplayerplugin/files/0.2.4-cmake.patch59
-rw-r--r--www-plugins/freshplayerplugin/freshplayerplugin-0.3.1-r2.ebuild82
-rw-r--r--www-plugins/freshplayerplugin/metadata.xml14
4 files changed, 156 insertions, 0 deletions
diff --git a/www-plugins/freshplayerplugin/Manifest b/www-plugins/freshplayerplugin/Manifest
new file mode 100644
index 000000000000..5971ccc3e422
--- /dev/null
+++ b/www-plugins/freshplayerplugin/Manifest
@@ -0,0 +1 @@
+DIST freshplayerplugin-0.3.1.tar.gz 2711793 SHA256 4ed582896fff618d8025dd51bbf2fae0c5e36e2875065acc536b2c76befb593c SHA512 78e87548ecd758ad9ff0dab59b1b2f68b8b9a639ff19de08046a7090ab51d87f0e4c879b1b0075151ff17642d50ff937e199733c55c4a9cff94599fd98eae9de WHIRLPOOL d8be949cc9a2087d8f62fcfb4a1786d68574a5ec52dccc45da06df9838ee84e8dd4d7f3c3f86703e428df1b3f4d6d75c1e87d0809d3f78550a16ed278d51b211
diff --git a/www-plugins/freshplayerplugin/files/0.2.4-cmake.patch b/www-plugins/freshplayerplugin/files/0.2.4-cmake.patch
new file mode 100644
index 000000000000..3ad1523e2ab5
--- /dev/null
+++ b/www-plugins/freshplayerplugin/files/0.2.4-cmake.patch
@@ -0,0 +1,59 @@
+diff -uarN a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2015-04-25 11:17:24.000000000 -0400
++++ b/CMakeLists.txt 2015-04-26 20:14:43.152014529 -0400
+@@ -61,35 +61,36 @@
+ # optional dependencies
+ message(STATUS "checking for optional dependencies")
+
+-pkg_check_modules(PULSEAUDIO QUIET libpulse)
+-pkg_check_modules(JACK QUIET jack)
+-pkg_check_modules(SOXR QUIET soxr)
+ set(WITH_PULSEAUDIO TRUE CACHE STRING "enable PulseAudio support")
+ set(WITH_JACK TRUE CACHE STRING "enable JACK Audio Connection Kit")
+
+-if (PULSEAUDIO_FOUND AND WITH_PULSEAUDIO)
++if (WITH_PULSEAUDIO)
++ pkg_check_modules(PULSEAUDIO libpulse)
++ if (NOT PULSEAUDIO_FOUND)
++ message(FATAL_ERROR "PulseAudio requested but not found.")
++ endif()
+ add_definitions(-DHAVE_PULSEAUDIO=1)
+- message(STATUS " found libpulse, version ${PULSEAUDIO_VERSION} (optional)")
++ message(STATUS " found libpulse, version ${PULSEAUDIO_VERSION}")
+ list(APPEND REQ_LIBRARY_DIRS ${PULSEAUDIO_LIBRARY_DIRS})
+ list(APPEND REQ_INCLUDE_DIRS ${PULSEAUDIO_INCLUDE_DIRS})
+ list(APPEND REQ_LIBRARIES ${PULSEAUDIO_LIBRARIES})
+-else()
+- message(STATUS " no libpulse found (optional)")
+ endif()
+
+-if (JACK_FOUND AND WITH_JACK)
+- message(STATUS " found jack, version ${JACK_VERSION} (optional)")
+- if (SOXR_FOUND)
+- message(STATUS " found soxr, version ${SOXR_VERSION}")
+- add_definitions(-DHAVE_JACK=1)
+- list(APPEND REQ_LIBRARY_DIRS "${JACK_LIBRARY_DIRS}" "${SOXR_LIBRARY_DIRS}")
+- list(APPEND REQ_INCLUDE_DIRS "${JACK_INCLUDE_DIRS}" "${SOXR_INCLUDE_DIRS}")
+- list(APPEND REQ_LIBRARIES "${JACK_LIBRARIES}" "${SOXR_LIBRARIES}")
+- else()
+- message(STATUS " no soxr found, JACK output disabled")
++if (WITH_JACK)
++ pkg_check_modules(JACK QUIET jack)
++ if (NOT JACK_FOUND)
++ message(FATAL_ERROR "JACK support requested but not found.")
++ endif()
++ pkg_check_modules(SOXR QUIET soxr)
++ if (NOT SOXR_FOUND)
++ message(FATAL_ERROR "SOXR libray not found but needed for JACK support.")
+ endif()
+-else()
+- message(STATUS " no jack found (optional)")
++ message(STATUS " found jack, version ${JACK_VERSION}")
++ message(STATUS " found soxr, version ${SOXR_VERSION}")
++ add_definitions(-DHAVE_JACK=1)
++ list(APPEND REQ_LIBRARY_DIRS "${JACK_LIBRARY_DIRS}" "${SOXR_LIBRARY_DIRS}")
++ list(APPEND REQ_INCLUDE_DIRS "${JACK_INCLUDE_DIRS}" "${SOXR_INCLUDE_DIRS}")
++ list(APPEND REQ_LIBRARIES "${JACK_LIBRARIES}" "${SOXR_LIBRARIES}")
+ endif()
+
+ list(APPEND REQ_LIBRARIES img-resources)
diff --git a/www-plugins/freshplayerplugin/freshplayerplugin-0.3.1-r2.ebuild b/www-plugins/freshplayerplugin/freshplayerplugin-0.3.1-r2.ebuild
new file mode 100644
index 000000000000..b01fdf3f7420
--- /dev/null
+++ b/www-plugins/freshplayerplugin/freshplayerplugin-0.3.1-r2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+# $Id$
+
+EAPI=5
+
+CMAKE_MIN_VERSION="2.8.8"
+
+inherit cmake-utils multilib
+
+LICENSE="MIT"
+HOMEPAGE="https://github.com/i-rinat/freshplayerplugin"
+DESCRIPTION="PPAPI-host NPAPI-plugin adapter for flashplayer in npapi based browsers"
+SRC_URI="https://github.com/i-rinat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT=0
+IUSE="gtk3 jack libav pulseaudio vaapi vdpau"
+
+KEYWORDS="~amd64 ~x86"
+
+HWDEC_DEPEND="
+ libav? ( media-video/libav:0=[vaapi?,vdpau?,x264] )
+ !libav? ( media-video/ffmpeg:0=[vaapi?,vdpau?,x264] )
+ x11-libs/libva
+ x11-libs/libvdpau
+"
+
+CDEPEND="
+ dev-libs/glib:2=
+ dev-libs/libconfig:=
+ dev-libs/libevent:=[threads]
+ dev-libs/openssl:0=
+ media-libs/alsa-lib:=
+ media-libs/freetype:2=
+ media-libs/libv4l:0=
+ media-libs/mesa:=[egl,gles2]
+ x11-libs/libXrandr:=
+ x11-libs/libXrender:=
+ x11-libs/pango:=[X]
+ jack? ( media-sound/jack-audio-connection-kit )
+ pulseaudio? ( media-sound/pulseaudio )
+ !gtk3? ( x11-libs/gtk+:2= )
+ gtk3? ( x11-libs/gtk+:3= )
+ vaapi? ( ${HWDEC_DEPEND} )
+ vdpau? ( ${HWDEC_DEPEND} )
+"
+
+DEPEND="${CDEPEND}
+ dev-util/ragel
+ virtual/pkgconfig
+ "
+RDEPEND="${CDEPEND}
+ || (
+ www-plugins/chrome-binary-plugins[flash]
+ www-client/google-chrome
+ www-client/google-chrome-beta
+ www-client/google-chrome-unstable
+ )
+ "
+
+PATCHES=( "${FILESDIR}/0.2.4-cmake.patch" )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with jack JACK)
+ $(cmake-utils_use_with pulseaudio PULSEAUDIO)
+ -DWITH_GTK=$(usex gtk3 3 2)
+ -DCMAKE_SKIP_RPATH=1
+ )
+ if use vaapi || use vdpau ; then
+ mycmakeargs+=( -DWITH_HWDEC=1 )
+ else
+ mycmakeargs+=( -DWITH_HWDEC=0 )
+ fi
+ cmake-utils_src_configure
+}
+
+src_install() {
+ dodoc ChangeLog data/freshwrapper.conf.example README.md
+ exeinto /usr/$(get_libdir)/nsbrowser/plugins
+ doexe "${BUILD_DIR}/libfreshwrapper-pepperflash.so"
+}
diff --git a/www-plugins/freshplayerplugin/metadata.xml b/www-plugins/freshplayerplugin/metadata.xml
new file mode 100644
index 000000000000..a2941a290b1f
--- /dev/null
+++ b/www-plugins/freshplayerplugin/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>grknight@gentoo.org</email>
+ <name>Brian Evans</name>
+ </maintainer>
+ <use>
+ <flag name="gtk3">Build with GTK+ 3 instead of GTK+ 2</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">i-rinat/freshplayerplugin</remote-id>
+ </upstream>
+</pkgmetadata>