summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-12-17 06:25:45 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-12-17 06:44:27 -0500
commit8e552d249c84b94f57ef6891fa9c88e3a5073a2a (patch)
treeb034e7b8dbab8ed1a201579f9b2a45297989987c /www-client/qutebrowser
parentdev-libs/intel-compute-runtime: drop 22.39.24347 (diff)
downloadgentoo-8e552d249c84b94f57ef6891fa9c88e3a5073a2a.tar.gz
gentoo-8e552d249c84b94f57ef6891fa9c88e3a5073a2a.tar.bz2
gentoo-8e552d249c84b94f57ef6891fa9c88e3a5073a2a.zip
www-client/qutebrowser: adjust asciidoc call for live
Upstream now calls `python3 -m asciidoc` to simplify some venv/pip handling but, given asciidoc is single target, matching pythons over this would be inconvenient (aka fails if asciidoc is 3.10 and qutebrowser is 3.11). Alternatively could make asciidoc multi-target but this works just fine if just swap it out for ["asciidoc"]. May review this solution eventually but won't worry too much if it's for live-only. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'www-client/qutebrowser')
-rw-r--r--www-client/qutebrowser/qutebrowser-3.0.0_pre9999.ebuild9
-rw-r--r--www-client/qutebrowser/qutebrowser-9999.ebuild8
2 files changed, 14 insertions, 3 deletions
diff --git a/www-client/qutebrowser/qutebrowser-3.0.0_pre9999.ebuild b/www-client/qutebrowser/qutebrowser-3.0.0_pre9999.ebuild
index 19f356ecb5d7..08fc978ae6f4 100644
--- a/www-client/qutebrowser/qutebrowser-3.0.0_pre9999.ebuild
+++ b/www-client/qutebrowser/qutebrowser-3.0.0_pre9999.ebuild
@@ -94,8 +94,13 @@ src_prepare() {
# let eclass handle python
sed -i '/setup.py/d' misc/Makefile || die
- # live version lacks pre-generated docs
- [[ ${PV} != *9999 ]] || ${EPYTHON} scripts/asciidoc2html.py || die
+ if [[ ${PV} == *9999 ]]; then
+ # call asciidoc(1) rather than the single target python module
+ sed '/cmdline = /s/= .*/= ["asciidoc"]/' \
+ -i scripts/asciidoc2html.py || die
+
+ "${EPYTHON}" scripts/asciidoc2html.py || die
+ fi
# disable unnecessary tests/plugins that need extras (_ignore not enough)
sed -e '/pytest-benchmark/d' -e 's/--benchmark[^ ]*//' \
diff --git a/www-client/qutebrowser/qutebrowser-9999.ebuild b/www-client/qutebrowser/qutebrowser-9999.ebuild
index 0521c244a164..c4bb985b2edc 100644
--- a/www-client/qutebrowser/qutebrowser-9999.ebuild
+++ b/www-client/qutebrowser/qutebrowser-9999.ebuild
@@ -74,7 +74,13 @@ src_prepare() {
# let eclass handle python
sed -i '/setup.py/d' misc/Makefile || die
- [[ ${PV} != 9999 ]] || ${EPYTHON} scripts/asciidoc2html.py || die
+ if [[ ${PV} == 9999 ]]; then
+ # call asciidoc(1) rather than the single target python module
+ sed '/cmdline = /s/= .*/= ["asciidoc"]/' \
+ -i scripts/asciidoc2html.py || die
+
+ "${EPYTHON}" scripts/asciidoc2html.py || die
+ fi
# these plugins/tests are unnecessary here and have extra dependencies
sed -e '/pytest-benchmark/d;s/--benchmark[^ ]*//' \