summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-08-16 11:38:17 -0400
committerMike Gilbert <floppym@gentoo.org>2023-08-16 11:38:17 -0400
commit4bd9171abe648c0bd921d2f4310e7a1150b3b41d (patch)
treecdde695d9ca8fe9d23009d16cbcd2370af55d89f /www-client/opera-beta
parentwww-client/opera: remove old (diff)
downloadgentoo-4bd9171abe648c0bd921d2f4310e7a1150b3b41d.tar.gz
gentoo-4bd9171abe648c0bd921d2f4310e7a1150b3b41d.tar.bz2
gentoo-4bd9171abe648c0bd921d2f4310e7a1150b3b41d.zip
www-client/opera-beta: automated bump (102.0.4880.10)
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'www-client/opera-beta')
-rw-r--r--www-client/opera-beta/Manifest1
-rw-r--r--www-client/opera-beta/opera-beta-102.0.4880.10.ebuild170
2 files changed, 171 insertions, 0 deletions
diff --git a/www-client/opera-beta/Manifest b/www-client/opera-beta/Manifest
index ccb2c152a474..1cb8931d5ad6 100644
--- a/www-client/opera-beta/Manifest
+++ b/www-client/opera-beta/Manifest
@@ -1,4 +1,5 @@
DIST opera-beta_101.0.4843.10_amd64.deb 107328080 BLAKE2B f3d6a517e8e5860649202f9ed839f1f5ad9532e1776ef8d6d118c4668a2e507e4c5d22ec647486e0211f44bbeddf674aca925f24f5b45f9c92306888f9c31d4a SHA512 eff96c0252f0908030c6a6a45477f51bcd81a7174c6c9dbffb91281782c1f22a81d8e914ce157200d1ac869562fd28871288f0e8851c09b2df7e2bb041a16b10
DIST opera-beta_101.0.4843.13_amd64.deb 107328832 BLAKE2B 14eef1e96a9674466a49f36fdd6f3b6bc57a33fa8e18739c3a26d28b290d9d0d15aa8f144f3ffb69a5b11410ed211ead5ecde10b854b30ad76a02bc7f7fd096f SHA512 dbab95c331a661d1ff4d5b4631226711c49ed9e86e6c396ea878c7070861bcea0589d85676da870d09b381e881c7025da6c8d82498af2b2239885bb608a565fe
DIST opera-beta_101.0.4843.19_amd64.deb 104917876 BLAKE2B 25bbffb8b20bb7b3e6a6caf6826b721986aa24805f9d4c99ff1da5567ad44c5048941a0c224ac094c17f11dfca5d7050b82b4c19d9101173ac3514fb681879bc SHA512 53c02445c1586e7b37656a95ac1e1269cd6ef719a5f7719cd762f0fac4f5c03ae218411eed08bea78496a33b7c0ab5aac9bd334ad472008d08f59130de3b453b
+DIST opera-beta_102.0.4880.10_amd64.deb 105782680 BLAKE2B c1d060ea86105dd1f799bbe7f7ed09bd24decc50b61c3ae3626621e241bf9df45518aebd759010f18b15fc7f6b168b82d3ce66126e8e4578c14efb8d8975877c SHA512 d41695c2962c28ad1090f01edff3d8a9f648f5ad643fd7a889cd82878626e1feea5d4a104bc327772377a19638a860046f47ebfab57a10278bdb117896512bdd
DIST opera-ffmpeg-codecs-114.0.5735.9.tar.xz 1315192 BLAKE2B ef9a0cfc8c30ac0a837863644f3c2d5e78059575e2b8f6fda9253304f4815a39d021602e802dac7e1d5a1685aa5015a02019c4a0399f0bdc81136f956cc1d55f SHA512 bdad66bd5d238bdeb81a4e2a956f0a814633360f05c7bed2161df9506d2ccc444445ba452cc8974c755fe0d3f46adceb90324a472a5dac72e9c65391ae7a841c
diff --git a/www-client/opera-beta/opera-beta-102.0.4880.10.ebuild b/www-client/opera-beta/opera-beta-102.0.4880.10.ebuild
new file mode 100644
index 000000000000..fa627a202454
--- /dev/null
+++ b/www-client/opera-beta/opera-beta-102.0.4880.10.ebuild
@@ -0,0 +1,170 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHROMIUM_LANGS="
+ bg bn ca cs da de el en-GB en-US es-419 es fil fi fr hi hr hu id
+ it ja ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi
+ zh-CN zh-TW
+"
+
+# These are intended for ebuild maintainer use to force RPM if DEB is not available.
+: ${OPERA_FORCE_RPM=no}
+
+inherit chromium-2 pax-utils xdg
+
+if [[ ${OPERA_FORCE_RPM} == yes ]]; then
+ inherit rpm
+ OPERA_ARCHIVE_EXT="rpm"
+else
+ inherit unpacker
+ OPERA_ARCHIVE_EXT="deb"
+fi
+
+DESCRIPTION="A fast and secure web browser"
+HOMEPAGE="https://www.opera.com/"
+LICENSE="OPERA-2018"
+SLOT="0"
+
+SRC_URI_BASE=(
+ "https://download1.operacdn.com/pub/${PN}"
+ "https://download2.operacdn.com/pub/${PN}"
+ "https://download3.operacdn.com/pub/${PN}"
+ "https://download4.operacdn.com/pub/${PN}"
+)
+
+if [[ ${PN} == opera ]]; then
+ MY_PN=${PN}-stable
+ SRC_URI_BASE=( "${SRC_URI_BASE[@]/%//desktop}" )
+else
+ MY_PN=${PN}
+fi
+
+KEYWORDS="-* ~amd64"
+
+FFMPEG_VERSION="114.0.5735.9"
+
+SRC_URI="${SRC_URI_BASE[@]/%//${PV}/linux/${MY_PN}_${PV}_amd64.${OPERA_ARCHIVE_EXT}}
+ proprietary-codecs? (
+ mirror+https://dev.gentoo.org/~sultan/distfiles/www-client/opera/opera-ffmpeg-codecs-${FFMPEG_VERSION}.tar.xz
+ )"
+
+IUSE="+proprietary-codecs +suid qt5 qt6"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ gnome-base/gsettings-desktop-schemas
+ media-libs/alsa-lib
+ media-libs/mesa[gbm(+)]
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/libxshmfence
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/pango
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[X]
+ dev-qt/qtwidgets:5
+ )
+ qt6? ( dev-qt/qtbase:6[gui,widgets] )
+"
+
+QA_PREBUILT="*"
+S=${WORKDIR}
+OPERA_HOME="opt/opera${PN#opera}"
+
+pkg_pretend() {
+ # Protect against people using autounmask overzealously
+ use amd64 || die "opera only works on amd64"
+}
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ dodir /
+ cd "${ED}" || die
+ if [[ ${OPERA_FORCE_RPM} == yes ]]; then
+ rpm_src_unpack "${A[0]}"
+ else
+ unpacker
+ fi
+
+ # move to /opt, bug #573052
+ mkdir -p "${OPERA_HOME%${PN}}"
+ if [[ ${OPERA_FORCE_RPM} == yes ]]; then
+ mv "usr/lib64/${PN}" "${OPERA_HOME%${PN}}" || die
+ else
+ mv "usr/lib/x86_64-linux-gnu/${PN}" "${OPERA_HOME%${PN}}" || die
+ fi
+ rm -r "usr/lib" || die
+
+ # disable auto update
+ rm "${OPERA_HOME}/${PN%-*}_autoupdate"{,.licenses,.version} || die
+
+ if [[ ${OPERA_FORCE_RPM} == yes ]]; then
+ rm "${OPERA_HOME}/setup_repo.sh" || die
+ else
+ rm -r "usr/share/lintian" || die
+
+ # fix docs
+ mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
+ gzip -d usr/share/doc/${PF}/changelog.gz || die
+ fi
+
+ # fix desktop file
+ sed -i \
+ -e 's|^TargetEnvironment|X-&|g' \
+ usr/share/applications/${PN}.desktop || die
+
+ # remove unused language packs
+ pushd "${OPERA_HOME}/localization" > /dev/null || die
+ chromium_remove_language_paks
+ popd > /dev/null || die
+
+ # setup opera symlink
+ rm "usr/bin/${PN}" || die
+ dosym "../../${OPERA_HOME}/${PN}" "/usr/bin/${PN}"
+
+ # install proprietary codecs
+ rm "${OPERA_HOME}/resources/ffmpeg_preload_config.json" || die
+ if use proprietary-codecs; then
+ mv lib_extra "${OPERA_HOME}"
+ fi
+
+ if ! use qt5; then
+ rm "${OPERA_HOME}/libqt5_shim.so" || die
+ fi
+ if ! use qt6; then
+ rm "${OPERA_HOME}/libqt6_shim.so" || die
+ fi
+
+ # pax mark opera, bug #562038
+ pax-mark m "${OPERA_HOME}/opera"
+ # enable suid sandbox if requested
+ use suid && fperms 4711 "/${OPERA_HOME}/opera_sandbox"
+}