summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2023-05-02 09:05:26 +0300
committerJoonas Niilola <juippis@gentoo.org>2023-05-02 09:05:26 +0300
commit013e35868a90289dc0798083ce1b6f816ef316cd (patch)
tree18e5c1fc8fe8b461f12a2640b858431dbfb860a8 /www-client/firefox
parentsys-cluster/minikube: add 1.30.1 (diff)
downloadgentoo-013e35868a90289dc0798083ce1b6f816ef316cd.tar.gz
gentoo-013e35868a90289dc0798083ce1b6f816ef316cd.tar.bz2
gentoo-013e35868a90289dc0798083ce1b6f816ef316cd.zip
www-client/firefox: update FILES_PER_UNIFIED_FILE logic (jumbo-build)
- switch to the original version. There's no reason to modify defaults if such a thing wasn't requested. Bug: https://bugs.gentoo.org/905431 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/firefox-112.0.2.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/www-client/firefox/firefox-112.0.2.ebuild b/www-client/firefox/firefox-112.0.2.ebuild
index 9b8d6211fc3a..f2cb2a975131 100644
--- a/www-client/firefox/firefox-112.0.2.ebuild
+++ b/www-client/firefox/firefox-112.0.2.ebuild
@@ -63,7 +63,7 @@ SLOT="rapid"
LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
IUSE="+clang cpu_flags_arm_neon dbus debug eme-free hardened hwaccel"
-IUSE+=" jack +jumbo-build libproxy lto +openh264 pgo pulseaudio sndio selinux"
+IUSE+=" jack jumbo-build libproxy lto +openh264 pgo pulseaudio sndio selinux"
IUSE+=" +system-av1 +system-harfbuzz +system-icu +system-jpeg +system-libevent +system-libvpx system-png system-python-libs +system-webp"
IUSE+=" +telemetry wayland wifi +X"
@@ -669,11 +669,12 @@ src_prepare() {
# Respect choice for "jumbo-build"
# Changing the value for FILES_PER_UNIFIED_FILE may not work, see #905431
- if use jumbo-build; then
+ if [[ ! -z ${FILES_PER_UNIFIED_FILE} ]] && use jumbo-build; then
local my_files_per_unified_file=${FILES_PER_UNIFIED_FILE:=16}
elog ""
- elog "jumbo-build enabled with ${my_files_per_unified_file}."
- elog "if you get a build failure, try -jumbo-build before opening a bug report."
+ elog "jumbo-build defaults modified to ${my_files_per_unified_file}."
+ elog "if you get a build failure, try undefining FILES_PER_UNIFIED_FILE,"
+ elog "if that fails try -jumbo-build before opening a bug report."
elog ""
sed -i -e "s/\"FILES_PER_UNIFIED_FILE\", 16/\"FILES_PER_UNIFIED_FILE\", "${my_files_per_unified_file}"/" python/mozbuild/mozbuild/frontend/data.py ||